aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/tp-link.mk
diff options
context:
space:
mode:
authorThomas Roberts <tom.p.roberts@gmail.com>2017-02-13 17:29:34 +0000
committerJohn Crispin <john@phrozen.org>2017-02-20 09:10:17 +0100
commitf9278337cf4b9c699a41dfc1e4c448213be53e61 (patch)
treeb19f276ce789c6c08784846ee3765d801548b84f /target/linux/ar71xx/image/tp-link.mk
parent7c9f5c7e6b43650315603db1fe03c1c2fb857135 (diff)
downloadupstream-f9278337cf4b9c699a41dfc1e4c448213be53e61.tar.gz
upstream-f9278337cf4b9c699a41dfc1e4c448213be53e61.tar.bz2
upstream-f9278337cf4b9c699a41dfc1e4c448213be53e61.zip
ar71xx: add support for TL-WR802N Version 2
This patch adds support for the TP-Link TL-WR802N Version 2. Specification: - SoC: Qualcomm Atheros QCA9533 (560 MHz, MIPS 24Kc) - RAM: 32 MiB - Storage: 4 MiB of FLash on board - Wireless: Built into QCA9533 (Honey Bee), PHY modes b/g/n - Ethernet: 1x100M (port0) Installation through OEM Web Interface: - Connect to TL-WR802N by Ethernet or Wi-Fi - Go to http://192.168.0.1 (default user is "admin" & password is "admin) - Go to "System Tools -> Firmware Upgrade" - Browse for firmware "*.factory-us.bin" or "*.factory-eu.bin" for eu model - Click upgrade Installation through tftp: Note: T_OUT, T_IN and GND on the board must be connected to USB TTL Serial Configuration 115200 8n1 - Boot the TL-WR802N - When "Autobooting in 1 seconds" appears type "tpl" followed by enter - Connect to the board Ethernet port (IPADDR: 192.168.1.1, ServerIP: 192.168.1.10) - tftpboot 0x80000000 <Firmware Image Name> - Record the result of "printenv bootcmd" - Enter "erase <Result of 'printenv bootcmd'> +0x3c0000" (e.g erase 0x9f020000 +0x3c0000) - Enter "cp.b 0x80000000 <Result of 'printenv bootcmd'> 0x3c0000" (e.g cp.b 0x80000000 0x9f020000 0x3c0000) - Enter "bootm <Result of 'printenv bootcmd'>" (e.g bootm 0x9f020000) Signed-off-by: Thomas Roberts <tom.p.roberts@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image/tp-link.mk')
-rw-r--r--target/linux/ar71xx/image/tp-link.mk16
1 files changed, 14 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/tp-link.mk b/target/linux/ar71xx/image/tp-link.mk
index 34b5390fca..b251135c55 100644
--- a/target/linux/ar71xx/image/tp-link.mk
+++ b/target/linux/ar71xx/image/tp-link.mk
@@ -631,12 +631,24 @@ TARGET_DEVICES += tl-wr740n-v1 tl-wr740n-v3 tl-wr740n-v4 tl-wr740n-v5 tl-wr740n-
define Device/tl-wr802n-v1
$(Device/tplink-4mlzma)
DEVICE_TITLE := TP-LINK TL-WR802N v1
- BOARDNAME := TL-WR802N-v1
+ BOARDNAME := TL-WR802N-v1
DEVICE_PROFILE := TLWR802
TPLINK_HWID := 0x08020001
TPLINK_HWREV := 1
endef
-TARGET_DEVICES += tl-wr802n-v1
+
+define Device/tl-wr802n-v2
+ $(Device/tplink-4mlzma)
+ DEVICE_TITLE := TP-LINK TL-WR802N v2
+ BOARDNAME := TL-WR802N-v2
+ DEVICE_PROFILE := TLWR802
+ TPLINK_HWID := 0x08020002
+ TPLINK_HWREV := 2
+ IMAGES += factory-us.bin factory-eu.bin
+ IMAGE/factory-us.bin := append-rootfs | mktplinkfw factory -C US
+ IMAGE/factory-eu.bin := append-rootfs | mktplinkfw factory -C EU
+endef
+TARGET_DEVICES += tl-wr802n-v1 tl-wr802n-v2
define Device/tl-wr841-v1.5
$(Device/tplink-4m)