aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/tp-link.mk
diff options
context:
space:
mode:
authorSteffen Weinreich <steve@weinreich.org>2017-04-27 23:59:22 +0200
committerJohn Crispin <john@phrozen.org>2017-05-18 14:47:53 +0200
commit224e5f5efa22b8a0132522367afd3b22f05d53e1 (patch)
tree6d53ab6c220b03aef69a0700ccf6c9d7133d64a7 /target/linux/ar71xx/image/tp-link.mk
parentec987e59c4a4c5bbf65e6e667fb13853270d58ae (diff)
downloadupstream-224e5f5efa22b8a0132522367afd3b22f05d53e1.tar.gz
upstream-224e5f5efa22b8a0132522367afd3b22f05d53e1.tar.bz2
upstream-224e5f5efa22b8a0132522367afd3b22f05d53e1.zip
ar71xx: Add support for Teltonika RUT900
Teltonika RUT900 is a Router with LTE dual SIM, WiFi, 4x Ethernet ports, I/O, RS232, RS485, GPS. The device ist based on a Atheros AR9344 rev 3, Specifications: - 560/450/225 MHz (CPU/DDR/AHB) - 128 MB of RAM - 16 MB of FLASH - Serial Console header on a Card Board edge connector - 4x 10/100 Mbps Ethernet (3x LAN, 1x WAN) - 2.4 GHz Wifi - 2x external, detachable Wifi antennas - LTE Modem Huawei ME909u-521 (Also other Modem seen) - 2x LTE antennas - 1x GPS antenna - 7x LED, 1x button - 1x USB Connector - 1x Serial RS232 - 1x Serial RS485 - 1x MicroSD Card The GPL sources of the device are available at www.teltonika.lt/gpl/ and are based on OpenWRT Barrier Breaker (14.07) Running from tftp: The Router starts into the uboot Webupdater if the Button ist pressed more than 3 seconds, if no Network cable is attached it starts the uboot serial console, from there the router loads the firmware image via tftpboot from 192.168.1.2:firmware.bin (the router has the 192.168.1.1). With bootm the loaded image will be booted. Signed-off-by: Steffen Weinreich <steve@weinreich.org>
Diffstat (limited to 'target/linux/ar71xx/image/tp-link.mk')
-rw-r--r--target/linux/ar71xx/image/tp-link.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/tp-link.mk b/target/linux/ar71xx/image/tp-link.mk
index 6ddf05239d..49e87cfb99 100644
--- a/target/linux/ar71xx/image/tp-link.mk
+++ b/target/linux/ar71xx/image/tp-link.mk
@@ -1084,3 +1084,14 @@ define Device/tl-wa7210n-v2
CONSOLE := ttyATH0,115200
endef
TARGET_DEVICES += tl-wa7210n-v2
+
+define Device/tlt-rut900
+ $(Device/tplink-16mlzma)
+ DEVICE_TITLE := Teltonika RUT900
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+ BOARDNAME := TLT-RUT900
+ DEVICE_PROFILE := TLTRUT900
+ TPLINK_HWID := 0x35000001
+ CONSOLE := ttyS0,115200
+endef
+TARGET_DEVICES += tlt-rut900