aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/tiny.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-07-12 06:29:43 +0200
committerMathias Kresin <dev@kresin.me>2018-07-12 18:15:19 +0200
commit621fa91a8295b50dfdfac22290200064afaeec4e (patch)
tree5530a6c5c0fd8979a0b5f0c36565334084c3bebe /target/linux/ar71xx/image/tiny.mk
parent671999157d6cd0b629304f86beec7d71fc998b09 (diff)
downloadupstream-621fa91a8295b50dfdfac22290200064afaeec4e.tar.gz
upstream-621fa91a8295b50dfdfac22290200064afaeec4e.tar.bz2
upstream-621fa91a8295b50dfdfac22290200064afaeec4e.zip
ar71xx: move boards to tiny subtarget
Move boards to the tiny subtarget which break the build if the kernel is set to "Optimize for performance". Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ar71xx/image/tiny.mk')
-rw-r--r--target/linux/ar71xx/image/tiny.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/tiny.mk b/target/linux/ar71xx/image/tiny.mk
new file mode 100644
index 0000000000..d96a7cd92d
--- /dev/null
+++ b/target/linux/ar71xx/image/tiny.mk
@@ -0,0 +1,33 @@
+define Build/mkbuffaloimg
+ $(STAGING_DIR_HOST)/bin/mkbuffaloimg -B $(BOARDNAME) \
+ -R $$(($(subst k, * 1024,$(ROOTFS_SIZE)))) \
+ -K $$(($(subst k, * 1024,$(KERNEL_SIZE)))) \
+ -i $@ -o $@.new
+ mv $@.new $@
+endef
+
+
+define Device/bhr-4grv2
+ DEVICE_TITLE := Buffalo BHR-4GRV2
+ BOARDNAME := BHR-4GRV2
+ ROOTFS_SIZE := 14528k
+ KERNEL_SIZE := 1472k
+ IMAGE_SIZE := 16000k
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,14528k(rootfs),1472k(kernel),64k(art)ro,16000k@0x50000(firmware)
+ IMAGES := sysupgrade.bin factory.bin
+ IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to $$$$(ROOTFS_SIZE) | append-kernel | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | mkbuffaloimg
+endef
+TARGET_DEVICES += bhr-4grv2
+
+define Device/zbt-we1526
+ DEVICE_TITLE := Zbtlink ZBT-WE1526
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2
+ BOARDNAME := ZBT-WE1526
+ IMAGE_SIZE := 16000k
+ KERNEL_SIZE := 1472k
+ ROOTFS_SIZE := 14528k
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,14528k(rootfs),1472k(kernel),64k(art)ro,16000k@0x50000(firmware)
+ IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to $$$$(ROOTFS_SIZE) | append-kernel | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += zbt-we1526 \ No newline at end of file