aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/nand.mk
diff options
context:
space:
mode:
authorMantas Pucka <mantas@8devices.com>2017-05-08 13:28:38 +0300
committerPiotr Dymacz <pepe2k@gmail.com>2017-05-15 22:43:33 +0200
commit68b5d34f69421264de6e5d77760fcc2bfe9ee687 (patch)
treef6e3f9a783b577cdc4acd484f1198873ed54e134 /target/linux/ar71xx/image/nand.mk
parent43a7a1a05e0906f8adacd9c09b5c0be79fc94de1 (diff)
downloadupstream-68b5d34f69421264de6e5d77760fcc2bfe9ee687.tar.gz
upstream-68b5d34f69421264de6e5d77760fcc2bfe9ee687.tar.bz2
upstream-68b5d34f69421264de6e5d77760fcc2bfe9ee687.zip
ar71xx: add support for 8devices Rambutan development board
Rambutan is a Wifi module based on QCA9550/9557 http://www.8devices.com/products/rambutan This commit adds basic support for Rambutan development kit Specification: - 720/600/200 MHz (CPU/DDR/AHB) - 128 MB of DDR2 RAM - 128 MB of NAND Flash - 1x 100Mbps Ethernet - 1x 1000Mbps Ethernet (PHY on dev-kit) - 1x Wifi radio 2x2 MIMO, dualband 2.4 and 5 GHz - 2x U.FL connectors on module, chip antennas on dev-kit - 1x miniPCIe slot - 1x USB2.0 host socket + 1x USB2.0 pins on 2.54mm header Flash instructions: Stock firmware is OpenWrt, so use: sysupgrade -n /tmp/lede-ar71xx-nand-rambutan-squashfs-sysupgrade.tar or upgarde from GUI (don't save config) Use factory image to flash from U-Boot: tftpboot 80060000 lede-ar71xx-nand-rambutan-squashfs-factory.ubi nand erase.part ubi nand write 80060000 ubi ${filesize} Signed-off-by: Mantas Pucka <mantas@8devices.com> [split support in uboot-envtools package into a separate commit, fixed alphabetical order in lib/preinit/05_set_iface_mac_ar71xx] Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image/nand.mk')
-rw-r--r--target/linux/ar71xx/image/nand.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/nand.mk b/target/linux/ar71xx/image/nand.mk
index 15e0809120..dfe78c2168 100644
--- a/target/linux/ar71xx/image/nand.mk
+++ b/target/linux/ar71xx/image/nand.mk
@@ -52,6 +52,20 @@ define Build/MerakiNAND-old
@mv $@.new $@
endef
+define Device/rambutan
+ DEVICE_TITLE := 8devices Rambutan
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2
+ BOARDNAME = RAMBUTAN
+ BLOCKSIZE = 128KiB
+ MTDPARTS = ar934x-nfc:3M(u-boot)ro,2M(u-boot-env),1M(art),122M(ubi)
+ PAGESIZE := 2048
+ KERNEL_IN_UBI := 1
+ IMAGES := factory.ubi sysupgrade.tar
+ IMAGE/sysupgrade.tar := sysupgrade-tar
+ IMAGE/factory.ubi := append-ubi
+endef
+TARGET_DEVICES += rambutan
+
define Device/z1
DEVICE_TITLE := Meraki Z1
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-spi-gpio kmod-ath9k kmod-owl-loader