aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/nand.mk
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2016-11-23 16:34:31 +0100
committerMathias Kresin <dev@kresin.me>2016-11-24 22:37:40 +0100
commit6998b8a054a48a598cf961c785f311c6f71408cd (patch)
treef4e0b306e25a9faa23315a520aaf94c17d70b533 /target/linux/ar71xx/image/nand.mk
parentae79c41286f0d9a97f2641450240ecac5465677d (diff)
downloadupstream-6998b8a054a48a598cf961c785f311c6f71408cd.tar.gz
upstream-6998b8a054a48a598cf961c785f311c6f71408cd.tar.bz2
upstream-6998b8a054a48a598cf961c785f311c6f71408cd.zip
ar71xx: move DomyWifi DW33D to nand subtarget
This device uses NAND FLASH, so it should be kept in nand subtarget. Also, inlcude in packages kmod-usb-ledtrig-usbport instead of obsolete kmod-ledtrig-usbdev. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image/nand.mk')
-rw-r--r--target/linux/ar71xx/image/nand.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/nand.mk b/target/linux/ar71xx/image/nand.mk
index aa43a91ee9..cf4c286bee 100644
--- a/target/linux/ar71xx/image/nand.mk
+++ b/target/linux/ar71xx/image/nand.mk
@@ -13,6 +13,17 @@ endef
TARGET_DEVICES += c-60
+define Device/domywifi-dw33d
+ DEVICE_TITLE := DomyWifi DW33D
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage kmod-usb-ledtrig-usbport kmod-ath10k
+ BOARDNAME = DW33D
+ IMAGE_SIZE = 16000k
+ CONSOLE = ttyS0,115200
+ MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,14528k(rootfs),1472k(kernel),64k(art)ro,16000k@0x50000(firmware);ar934x-nfc:96m(rootfs_data),32m(backup)ro
+ IMAGE/sysupgrade.bin = append-rootfs | pad-rootfs | pad-to 14528k | append-kernel | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += domywifi-dw33d
+
define Build/MerakiNAND
-$(STAGING_DIR_HOST)/bin/mkmerakifw \
-B $(BOARDNAME) -s \