aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/legacy-devices.mk
diff options
context:
space:
mode:
authorCamille Bilodeau <camille.bilodeau@protonmail.com>2017-06-13 10:05:13 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2017-06-29 10:37:36 +0200
commitbb46b635df48d5c2368f98646c16e3333cbc11fb (patch)
treeded054933b8b2a7c9089186caa2e12ba73c00c0a /target/linux/ar71xx/image/legacy-devices.mk
parent2fa58a8d7c340cd6b9c1d9be401d43a2ac8125e3 (diff)
downloadupstream-bb46b635df48d5c2368f98646c16e3333cbc11fb.tar.gz
upstream-bb46b635df48d5c2368f98646c16e3333cbc11fb.tar.bz2
upstream-bb46b635df48d5c2368f98646c16e3333cbc11fb.zip
ar71xx: move Arduino Yun to generic building code
Migrate Arduino Yun from legacy to generic building code. Note: the mtd partitioning is changed to adopt the LEDE default partitioning. It allows to have a kernel bigger than 1280k. It is necessary as kernel > 4.4 with default LEDE configuration grows bigger. To use the new partitioning, you need to update your U-Boot env in advance: setenv mtdparts "spi0.0:256k(u-boot)ro,64k(u-boot-env),15936k(firmware),64k(nvram),64k(art)ro" setenv bootcmd "run addboard; run addtty; run addparts; run addrootfs; bootm 0x9f050000 || bootm 0x9fea0000" saveenv Signed-off-by: Camille Bilodeau <camille.bilodeau@protonmail.com>
Diffstat (limited to 'target/linux/ar71xx/image/legacy-devices.mk')
-rw-r--r--target/linux/ar71xx/image/legacy-devices.mk6
1 files changed, 0 insertions, 6 deletions
diff --git a/target/linux/ar71xx/image/legacy-devices.mk b/target/linux/ar71xx/image/legacy-devices.mk
index e3aeb592bd..77230249af 100644
--- a/target/linux/ar71xx/image/legacy-devices.mk
+++ b/target/linux/ar71xx/image/legacy-devices.mk
@@ -167,12 +167,6 @@ define LegacyDevice/WLR8100
endef
LEGACY_DEVICES += WLR8100
-define LegacyDevice/YUN_16M
- DEVICE_TITLE := Arduino Yun based on Atheros AR9331 (16MB flash)
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2
-endef
-LEGACY_DEVICES += YUN_16M
-
define LegacyDevice/F9K1115V2
DEVICE_TITLE := Belkin AC1750DB (F9K1115V2)
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb3 kmod-usb-ledtrig-usbport \