aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/legacy-devices.mk
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2016-08-18 00:05:03 +0200
committerJohn Crispin <john@phrozen.org>2016-08-18 09:49:18 +0200
commitf478fba663d3ea1bf919137277b9a81344006173 (patch)
tree73907f5cdf110c0e8992b64e13a54c11f5c5c004 /target/linux/ar71xx/image/legacy-devices.mk
parent57ef81d78f590c86aaebeb41c14528b33b73db94 (diff)
downloadupstream-f478fba663d3ea1bf919137277b9a81344006173.tar.gz
upstream-f478fba663d3ea1bf919137277b9a81344006173.tar.bz2
upstream-f478fba663d3ea1bf919137277b9a81344006173.zip
ar71xx: add support for Zbtlink ZBT-WE1526
Zbtlink ZBT-WE1526 is based on Qualcomm Atheros QCA9531 v2. Short specification: - 650/400/200 MHz (CPU/DDR/AHB) - 5x 10/100 Mbps Ethernet - 1x USB 2.0 - 128 MB of RAM (DDR2) - 16 MB of FLASH - 2T2R 2.4 GHz, up to 22 dBm - two external, non-detachable antennas - 8x LED, 1x button - UART header (pinout: VCC, RX, TX, GND) Flash instruction: Use sysupgrade in vendor firmare which is based on OpenWrt. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image/legacy-devices.mk')
-rw-r--r--target/linux/ar71xx/image/legacy-devices.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/legacy-devices.mk b/target/linux/ar71xx/image/legacy-devices.mk
index 1d295f1006..72114cdce9 100644
--- a/target/linux/ar71xx/image/legacy-devices.mk
+++ b/target/linux/ar71xx/image/legacy-devices.mk
@@ -705,6 +705,12 @@ define LegacyDevice/WZR450HP2
endef
LEGACY_DEVICES += WZR450HP2
+define LegacyDevice/ZBTWE1526
+ DEVICE_TITLE := Zbtlink ZBT-WE1526
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2
+endef
+LEGACY_DEVICES += ZBTWE1526
+
define LegacyDevice/ZCN1523H28
DEVICE_TITLE := Zcomax ZCN-1523H-2-8
endef