aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic.mk
diff options
context:
space:
mode:
authorCamille Bilodeau <camille.bilodeau@protonmail.com>2017-06-13 10:05:13 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2017-06-29 10:37:36 +0200
commitbb46b635df48d5c2368f98646c16e3333cbc11fb (patch)
treeded054933b8b2a7c9089186caa2e12ba73c00c0a /target/linux/ar71xx/image/generic.mk
parent2fa58a8d7c340cd6b9c1d9be401d43a2ac8125e3 (diff)
downloadupstream-bb46b635df48d5c2368f98646c16e3333cbc11fb.tar.gz
upstream-bb46b635df48d5c2368f98646c16e3333cbc11fb.tar.bz2
upstream-bb46b635df48d5c2368f98646c16e3333cbc11fb.zip
ar71xx: move Arduino Yun to generic building code
Migrate Arduino Yun from legacy to generic building code. Note: the mtd partitioning is changed to adopt the LEDE default partitioning. It allows to have a kernel bigger than 1280k. It is necessary as kernel > 4.4 with default LEDE configuration grows bigger. To use the new partitioning, you need to update your U-Boot env in advance: setenv mtdparts "spi0.0:256k(u-boot)ro,64k(u-boot-env),15936k(firmware),64k(nvram),64k(art)ro" setenv bootcmd "run addboard; run addtty; run addparts; run addrootfs; bootm 0x9f050000 || bootm 0x9fea0000" saveenv Signed-off-by: Camille Bilodeau <camille.bilodeau@protonmail.com>
Diffstat (limited to 'target/linux/ar71xx/image/generic.mk')
-rw-r--r--target/linux/ar71xx/image/generic.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 56dcf5c997..5a7a509fbd 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -92,6 +92,16 @@ define Device/ap90q
endef
TARGET_DEVICES += ap90q
+define Device/arduino-yun
+ DEVICE_TITLE := Arduino Yun
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2
+ BOARDNAME := Yun
+ IMAGE_SIZE := 15936k
+ CONSOLE = ttyATH0,250000
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),15936k(firmware),64k(nvram),64k(art)ro
+endef
+TARGET_DEVICES += arduino-yun
+
define Device/bsb
DEVICE_TITLE := Smart Electronics Black Swift board
DEVICE_PACKAGES := kmod-usb-core kmod-usb2