aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic.mk
diff options
context:
space:
mode:
authorChristian Mehlis <christian@m3hlis.de>2017-03-28 21:16:43 +0200
committerJohn Crispin <john@phrozen.org>2017-03-29 09:04:08 +0200
commitbe11ce8f26bfa58c110434ccf673c0411402b171 (patch)
treebf3e7e630e862171853aeeca1ee2f78a39b50324 /target/linux/ar71xx/image/generic.mk
parent0af487033e6af390686ed2bc693beab7b467eaf3 (diff)
downloadupstream-be11ce8f26bfa58c110434ccf673c0411402b171.tar.gz
upstream-be11ce8f26bfa58c110434ccf673c0411402b171.tar.bz2
upstream-be11ce8f26bfa58c110434ccf673c0411402b171.zip
ar71xx: move Compex WPJ342 to generic build target
Signed-off-by: Christian Mehlis <christian@m3hlis.de>
Diffstat (limited to 'target/linux/ar71xx/image/generic.mk')
-rw-r--r--target/linux/ar71xx/image/generic.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 54835a5634..cd5e40163d 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -790,6 +790,16 @@ define Device/bhr-4grv2
endef
TARGET_DEVICES += bhr-4grv2
+define Device/wpj342
+ DEVICE_TITLE := Compex WPJ342 (16MB flash)
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
+ BOARDNAME := WPJ342
+ MTDPARTS := spi0.0:192k(u-boot)ro,16128k(firmware),64k(art)ro
+ IMAGE_SIZE := 16128k
+ CONSOLE := ttyS0,115200
+endef
+TARGET_DEVICES += wpj342
+
define Device/wpj344
DEVICE_TITLE := Compex WPJ344 (16MB flash)
DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport