aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic.mk
diff options
context:
space:
mode:
authorChristian Mehlis <christian@m3hlis.de>2017-03-28 21:09:37 +0200
committerJohn Crispin <john@phrozen.org>2017-03-29 09:04:08 +0200
commitf940fe8964b8fcdab04bffafafe0c3e02ebf4c27 (patch)
treec36a454aa44dbc9b54fcf4bca61f0b159e0badf4 /target/linux/ar71xx/image/generic.mk
parent513dff3cca9a8f800c63ccda7a4d0a168f48a814 (diff)
downloadupstream-f940fe8964b8fcdab04bffafafe0c3e02ebf4c27.tar.gz
upstream-f940fe8964b8fcdab04bffafafe0c3e02ebf4c27.tar.bz2
upstream-f940fe8964b8fcdab04bffafafe0c3e02ebf4c27.zip
ar71xx: move Compex WPJ558 to generic build target
Signed-off-by: Christian Mehlis <christian@m3hlis.de>
Diffstat (limited to 'target/linux/ar71xx/image/generic.mk')
-rw-r--r--target/linux/ar71xx/image/generic.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index bbe52d23b5..91d4ef7567 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -789,3 +789,13 @@ define Device/bhr-4grv2
IMAGE/factory.bin = append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | mkbuffaloimg
endef
TARGET_DEVICES += bhr-4grv2
+
+define Device/wpj558
+ DEVICE_TITLE := Compex WPJ558 (16MB flash)
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
+ BOARDNAME := WPJ558
+ MTDPARTS := spi0.0:192k(u-boot)ro,16128k(firmware),64k(art)ro
+ IMAGE_SIZE := 16128k
+ CONSOLE := ttyS0,115200
+endef
+TARGET_DEVICES += wpj558