aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic.mk
diff options
context:
space:
mode:
authorChris Blake <chrisrblake93@gmail.com>2016-10-24 14:05:53 -0500
committerJohn Crispin <john@phrozen.org>2016-10-26 12:37:44 +0200
commitd8662ac3c6a2ecd3834d109c5d3abd864fb23a50 (patch)
treeb23be070cb4e581d6c778cb26533adbe620f2253 /target/linux/ar71xx/image/generic.mk
parent7b9ac39afa48a4ffd9858c43d93106771447aa0b (diff)
downloadupstream-d8662ac3c6a2ecd3834d109c5d3abd864fb23a50.tar.gz
upstream-d8662ac3c6a2ecd3834d109c5d3abd864fb23a50.tar.bz2
upstream-d8662ac3c6a2ecd3834d109c5d3abd864fb23a50.zip
ar71xx: Move MR12 & MR16 from legacy to generic
This moves the Meraki MR12 and Meraki MR16 to the new generic target. Tested and verified working on both devices. Note that kernel/rootfs images are still generated. This is because they are used for the inital flashing process due to the fun pace at which UBoot erases/writes to SPI. Signed-off-by: Chris Blake <chrisrblake93@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image/generic.mk')
-rw-r--r--target/linux/ar71xx/image/generic.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index bf17814dda..4a81a17d67 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -108,6 +108,32 @@ define Device/gl-mifi
endef
TARGET_DEVICES += gl-mifi
+define Device/mr12
+ DEVICE_TITLE := Meraki MR12
+ DEVICE_PACKAGES := kmod-spi-gpio
+ BOARDNAME = MR12
+ IMAGE_SIZE = 15744k
+ MTDPARTS = spi0.0:256k(u-boot)ro,256k(u-boot-env)ro,13440k(rootfs),2304k(kernel),128k(art)ro,15744k@0x80000(firmware)
+ IMAGE/kernel.bin = append-kernel
+ IMAGE/rootfs.bin = append-rootfs | pad-rootfs
+ IMAGE/sysupgrade.bin = append-rootfs | pad-rootfs | pad-to 13440k | append-kernel | check-size $$$$(IMAGE_SIZE)
+ IMAGES := kernel.bin rootfs.bin sysupgrade.bin
+endef
+TARGET_DEVICES += mr12
+
+define Device/mr16
+ DEVICE_TITLE := Meraki MR16
+ DEVICE_PACKAGES := kmod-spi-gpio
+ BOARDNAME = MR16
+ IMAGE_SIZE = 15744k
+ MTDPARTS = spi0.0:256k(u-boot)ro,256k(u-boot-env)ro,13440k(rootfs),2304k(kernel),128k(art)ro,15744k@0x80000(firmware)
+ IMAGE/kernel.bin = append-kernel
+ IMAGE/rootfs.bin = append-rootfs | pad-rootfs
+ IMAGE/sysupgrade.bin = append-rootfs | pad-rootfs | pad-to 13440k | append-kernel | check-size $$$$(IMAGE_SIZE)
+ IMAGES := kernel.bin rootfs.bin sysupgrade.bin
+endef
+TARGET_DEVICES += mr16
+
define Device/dr531
DEVICE_TITLE := Wallys DR531
DEVICE_PACKAGES := kmod-usb-core kmod-usb2