aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-09-22 12:06:25 +0200
committerDavid Bauer <mail@david-bauer.net>2019-10-06 21:28:49 +0200
commit794d4b66523f88ba7b420d973c8418c40d371a17 (patch)
tree1acadf1c78269af6221ca79e7e1b78f68e16137c /target/linux/ar71xx/image/generic-ubnt.mk
parent3b874c2c819f7ca87668e53f2b366a70d27eea61 (diff)
downloadupstream-794d4b66523f88ba7b420d973c8418c40d371a17.tar.gz
upstream-794d4b66523f88ba7b420d973c8418c40d371a17.tar.bz2
upstream-794d4b66523f88ba7b420d973c8418c40d371a17.zip
treewide: remove kmod-usb-core from DEVICE_PACKAGES
This removes _all_ occurrences of kmod-usb-core from DEVICE_PACKAGES and similar variables. This package is pulled as dependency by one of the following packages in any case: - kmod-usb-chipidea - kmod-usb-dwc2 - kmod-usb-ledtrig-usbport - kmod-usb-ohci - kmod-usb2 - kmod-usb2-pci - kmod-usb3 Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> [remove kmod-usb-core from EnGenius ESR600] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ar71xx/image/generic-ubnt.mk')
-rw-r--r--target/linux/ar71xx/image/generic-ubnt.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ar71xx/image/generic-ubnt.mk b/target/linux/ar71xx/image/generic-ubnt.mk
index 5caad50b0a..5a4517f81f 100644
--- a/target/linux/ar71xx/image/generic-ubnt.mk
+++ b/target/linux/ar71xx/image/generic-ubnt.mk
@@ -43,7 +43,7 @@ endef
# UBNT_CHIP e.g. one of (ar7240, ar933x, ar934x)
# UBNT_VERSION e.g. one of (6.0.0, 8.5.0)
define Device/ubnt
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2
+ DEVICE_PACKAGES := kmod-usb2
DEVICE_PROFILE := UBNT
IMAGE_SIZE := 7552k
MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,7552k(firmware),256k(cfg)ro,64k(EEPROM)ro
@@ -121,7 +121,7 @@ endef
TARGET_DEVICES += ubnt-unifi
define Device/ubnt-unifiac
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2
+ DEVICE_PACKAGES := kmod-usb2
DEVICE_PROFILE := UBNT
IMAGE_SIZE := 7744k
MTDPARTS := spi0.0:384k(u-boot)ro,64k(u-boot-env)ro,7744k(firmware),7744k(ubnt-airos)ro,128k(bs),256k(cfg)ro,64k(EEPROM)ro
@@ -239,7 +239,7 @@ endef
TARGET_DEVICES += ubdev01
define Device/ubnt-routerstation
- DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2
+ DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2
DEVICE_PROFILE := UBNT
IMAGE_SIZE := 16128k
IMAGES := sysupgrade.bin factory.bin