aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorHenryk Heisig <hyniu@o2.pl>2018-02-06 22:08:28 +0100
committerJohn Crispin <john@phrozen.org>2018-02-13 09:21:20 +0100
commita338491a306798868738fd8210b27bd2a4ab0daa (patch)
tree8ff16b02274a21dcd0d94d4d66f8cf59f430ed2c /target/linux/ar71xx/image/generic-tp-link.mk
parent78f5af626c2da3816b71b5e4c560516f8ee383b2 (diff)
downloadupstream-a338491a306798868738fd8210b27bd2a4ab0daa.tar.gz
upstream-a338491a306798868738fd8210b27bd2a4ab0daa.tar.bz2
upstream-a338491a306798868738fd8210b27bd2a4ab0daa.zip
ar71xx: add support for TP-Link RE355
This device is identical as TP-Link RE450 RE355 is a dual-band AC1200 router, based on Qualcomm/Atheros QCA9558+QCA9880. Specification: 720/600/200 MHz (CPU/DDR/AHB) 64/128 MB of RAM (DDR2) 8 MB of FLASH (SPI NOR) 3T3R 2.4 GHz 3T3R 5 GHz 1x 10/100/1000 Mbps Ethernet 7x LED, 3x button UART header on PCB Flash instruction: Web: Download lede-ar71xx-generic-archer-c60-v2-squashfs-factory.bin and use OEM System Tools - Firmware Upgrade site. Signed-off-by: Henryk Heisig <hyniu@o2.pl>
Diffstat (limited to 'target/linux/ar71xx/image/generic-tp-link.mk')
-rw-r--r--target/linux/ar71xx/image/generic-tp-link.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic-tp-link.mk b/target/linux/ar71xx/image/generic-tp-link.mk
index b0d99e2599..48eed6b15b 100644
--- a/target/linux/ar71xx/image/generic-tp-link.mk
+++ b/target/linux/ar71xx/image/generic-tp-link.mk
@@ -184,6 +184,25 @@ define Device/eap120-v1
endef
TARGET_DEVICES += eap120-v1
+define Device/re355-v1
+ DEVICE_TITLE := TP-LINK RE355 v1
+ DEVICE_PACKAGES := kmod-ath10k ath10k-firmware-qca988x
+ MTDPARTS := spi0.0:128k(u-boot)ro,6016k(firmware),64k(partition-table)ro,64k(product-info)ro,1856k(config)ro,64k(art)ro
+ IMAGE_SIZE := 7936k
+ BOARDNAME := RE355
+ TPLINK_BOARD_ID := RE355
+ DEVICE_PROFILE := RE355
+ LOADER_TYPE := elf
+ TPLINK_HWID := 0x0
+ TPLINK_HWREV := 0
+ TPLINK_HEADER_VERSION := 1
+ KERNEL := kernel-bin | patch-cmdline | lzma | tplink-v1-header
+ IMAGES := sysupgrade.bin factory.bin
+ IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade
+ IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
+endef
+TARGET_DEVICES += re355-v1
+
define Device/re450-v1
DEVICE_TITLE := TP-LINK RE450 v1
DEVICE_PACKAGES := kmod-ath10k ath10k-firmware-qca988x