aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic-legacy-devices.mk
diff options
context:
space:
mode:
authorDavide Fioravanti <pantanastyle@gmail.com>2017-11-19 21:11:10 +0100
committerPiotr Dymacz <pepe2k@gmail.com>2018-01-15 00:12:13 +0100
commita85db951db31c607f423747842e3d1d102c8fc9a (patch)
treef9861674864f3237a6995ed9a335d759e3875fa4 /target/linux/ar71xx/image/generic-legacy-devices.mk
parentec141c1f3dffadd5f1e5c98697e686cc14897701 (diff)
downloadupstream-a85db951db31c607f423747842e3d1d102c8fc9a.tar.gz
upstream-a85db951db31c607f423747842e3d1d102c8fc9a.tar.bz2
upstream-a85db951db31c607f423747842e3d1d102c8fc9a.zip
ar71xx: fix Sitecom WLR-8100 support
This patch fixes Sitecom WLR-8100: - mtd layout - LAN and WAN MAC address setup - 2.4 GHz Wi-Fi MAC address setup - 5 GHz Wi-Fi support (calibration data, MAC address setup, missing ath10k-* packages) Signed-off-by: Davide Fioravanti <pantanastyle@gmail.com> [squashed commits, fixed whitespace issues, reworded commit message] Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/image/generic-legacy-devices.mk')
-rw-r--r--target/linux/ar71xx/image/generic-legacy-devices.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/generic-legacy-devices.mk b/target/linux/ar71xx/image/generic-legacy-devices.mk
index 70e32748b6..addfb23d2c 100644
--- a/target/linux/ar71xx/image/generic-legacy-devices.mk
+++ b/target/linux/ar71xx/image/generic-legacy-devices.mk
@@ -145,7 +145,8 @@ LEGACY_DEVICES += TUBE2H16M
define LegacyDevice/WLR8100
DEVICE_TITLE := Sitecom WLR-8100
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-usb3
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-usb3 \
+ kmod-ath10k ath10k-firmware-qca988x
endef
LEGACY_DEVICES += WLR8100