aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-24 08:58:20 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-24 08:58:20 +0000
commit26d0a2beff51ff398a4447572cfa1d886a0005ad (patch)
tree3962fbbd45fcadf68911c6b89f9f1413e0f0977b /target/linux/ar71xx/image/Makefile
parente6956d528c8c7d0e091c5f987d39bdbaf108746d (diff)
downloadupstream-26d0a2beff51ff398a4447572cfa1d886a0005ad.tar.gz
upstream-26d0a2beff51ff398a4447572cfa1d886a0005ad.tar.bz2
upstream-26d0a2beff51ff398a4447572cfa1d886a0005ad.zip
v3: CC : ar71xx: Backport Support for the Bitmain Antminer S3
Backport of r46236 to CC : add support for the Bitmain Antminer S3 Signed-off-by: L. D. Pinney <ldpinney@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46445 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index b334f017d0..cc0105b4b3 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -287,6 +287,14 @@ define Device/antminer-s1
CONSOLE := ttyATH0,115200
endef
+define Device/antminer-s3
+ $(Device/tplink-8mlzma)
+ BOARDNAME := ANTMINER-S3
+ DEVICE_PROFILE := ANTMINER_S3
+ TPLINK_HWID := 0x04440003
+ CONSOLE := ttyATH0,115200
+endef
+
define Device/el-m150
$(Device/tplink-8mlzma)
BOARDNAME := EL-M150
@@ -302,7 +310,7 @@ define Device/el-mini
TPLINK_HWID := 0x01530001
CONSOLE := ttyATH0,115200
endef
-TARGET_DEVICES += antminer-s1 el-m150 el-mini
+TARGET_DEVICES += antminer-s1 antminer-s3 el-m150 el-mini
define Device/gl-inet-6408A-v1
$(Device/tplink-8mlzma)