aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-10-11 16:23:44 +0000
committerJohn Crispin <john@openwrt.org>2015-10-11 16:23:44 +0000
commit5816fa9a981615dbb967722b2ae3999d6aab30a3 (patch)
tree0d32d58a5bf4392f5f65c7dbd288e3f4de3a9575 /target/linux/ar71xx/image/Makefile
parent6f59ea0e8021bb81a8b66b6903399cae4731f217 (diff)
downloadupstream-5816fa9a981615dbb967722b2ae3999d6aab30a3.tar.gz
upstream-5816fa9a981615dbb967722b2ae3999d6aab30a3.tar.bz2
upstream-5816fa9a981615dbb967722b2ae3999d6aab30a3.zip
ar71xx/image: add options argument to mktplinkfw step
Allow to pass extra arguments to mktplinkfw step. Some board requires an extra argument to create a valid image. Signed-off-by: Alexander Couzens <lynxis@fe80.eu> SVN-Revision: 47174
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index c90891716c..2dd7798f21 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -38,13 +38,16 @@ define Build/netgear-uImage
endef
# combine kernel and rootfs into one image
+# mktplinkfw <type> <optional extra arguments to mktplinkfw binary>
+# <type> is "sysupgrade" or "factory"
+#
# -a align the rootfs start on an <align> bytes boundary
# -j add jffs2 end-of-filesystem markers
# -s strip padding from end of the image
# -X reserve <size> bytes in the firmware image (hexval prefixed with 0x)
define Build/mktplinkfw
-$(STAGING_DIR_HOST)/bin/mktplinkfw \
- -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) \
+ -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) $2 \
-k $(word 1,$^) \
-r $@ \
-o $@.new \
@@ -64,10 +67,12 @@ define Build/mktplinkfw-chn-v2
$(if $(findstring sysupgrade,$1),-s) && mv $@.new $@ || rm -f $@
endef
+# mktplinkfw-initramfs <optional extra arguments to mktplinkfw binary>
+#
# -c combined image
define Build/mktplinkfw-initramfs
$(STAGING_DIR_HOST)/bin/mktplinkfw \
- -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) \
+ -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) $2 \
-k $@ \
-o $@.new \
-s -S \