aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-09-04 14:45:09 +0000
committerJonas Gorski <jogo@openwrt.org>2015-09-04 14:45:09 +0000
commitb958c12d2c646a787f1eb37a334c3492778535c3 (patch)
tree3e7bfe8ee202ecc0552c97ce7266895929514450 /target/linux/ar71xx/image/Makefile
parent156a25b9c45a91dcd885affa799345e66a0f1319 (diff)
downloadupstream-b958c12d2c646a787f1eb37a334c3492778535c3.tar.gz
upstream-b958c12d2c646a787f1eb37a334c3492778535c3.tar.bz2
upstream-b958c12d2c646a787f1eb37a334c3492778535c3.zip
image: move netgear-image to top and rename to -dni
Use the same naming as netgear-chk. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46791
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile13
1 files changed, 2 insertions, 11 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 04597f2c82..e6fe36ad09 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -37,15 +37,6 @@ define Build/netgear-uImage
$(call Build/uImage,$(1) -M $(NETGEAR_KERNEL_MAGIC))
endef
-define Build/netgear-image
- $(STAGING_DIR_HOST)/bin/mkdniimg \
- -B $(NETGEAR_BOARD_ID) -v OpenWrt.$(REVISION) \
- $(if $(NETGEAR_HW_ID),-H $(NETGEAR_HW_ID)) \
- -r "$(1)" \
- -i $@ -o $@.new
- mv $@.new $@
-endef
-
# combine kernel and rootfs into one image
# -a align the rootfs start on an <align> bytes boundary
# -j add jffs2 end-of-filesystem markers
@@ -198,8 +189,8 @@ define Device/wndr3700
KERNEL := kernel-bin | patch-cmdline | lzma -d20 | netgear-uImage lzma
IMAGE/default = append-kernel $$$$(BLOCKSIZE) | netgear-squashfs | append-rootfs | pad-rootfs
IMAGE/sysupgrade.bin = $$(IMAGE/default) | check-size $$$$(IMAGE_SIZE)
- IMAGE/factory.img = $$(IMAGE/default) | netgear-image | check-size $$$$(IMAGE_SIZE)
- IMAGE/factory-NA.img = $$(IMAGE/default) | netgear-image NA | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory.img = $$(IMAGE/default) | netgear-dni | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory-NA.img = $$(IMAGE/default) | netgear-dni NA | check-size $$$$(IMAGE_SIZE)
endef
define Device/wndr3700v2