aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-12-23 14:43:35 +0000
committerJohn Crispin <john@openwrt.org>2015-12-23 14:43:35 +0000
commit772f9d4e32f326d94050da157d108f7f97961c5f (patch)
treee85085e84a6f0945c6da35162b88cdfbad804482 /target/linux/ar71xx/image/Makefile
parent4ea610da74fd384faeb6313c783f16451872734b (diff)
downloadupstream-772f9d4e32f326d94050da157d108f7f97961c5f.tar.gz
upstream-772f9d4e32f326d94050da157d108f7f97961c5f.tar.bz2
upstream-772f9d4e32f326d94050da157d108f7f97961c5f.zip
ar71xx: Add support for AirTight Networks C-55
This patch is to add support for the AirTight Networks C-55 Access Point Signed-off-by: Chris R Blake <chrisrblake93@gmail.com> SVN-Revision: 47973
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 61c76a342b..d214eaefef 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -2308,6 +2308,16 @@ $(eval $(call BuildTemplate,256k,,256k))
$(eval $(call BuildTemplate,all,,64k 128k 256k))
ifeq ($(SUBTARGET),generic)
+define Device/c-55
+ BOARDNAME = C-55
+ KERNEL_SIZE = 2048k
+ IMAGE_SIZE = 15872k
+ MTDPARTS = spi0.0:256k(u-boot)ro,128k(u-boot-env)ro,2048k(kernel),13824k(rootfs),13824k(opt)ro,2624k(failsafe)ro,64k(art)ro,15872k@0x60000(firmware)
+ IMAGE/sysupgrade.bin = append-kernel $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+endef
+
+TARGET_DEVICES += c-55
+
$(eval $(call SingleProfile,ALFA,64k,ALFANX,alfa-nx,ALFA-NX,ttyS0,115200,$$(alfa_mtdlayout_8M),1638400,6291456,vmlinux.gz.uImage,pb9x-2.6.31-jffs2))
$(eval $(call SingleProfile,ALFA,64k,HORNETUB,hornet-ub,HORNET-UB,ttyATH0,115200,$$(alfa_mtdlayout_8M),1638400,6291456,kernel_image,rootfs_image))
$(eval $(call SingleProfile,ALFA,64k,TUBE2H8M,tube2h-8M,TUBE2H,ttyATH0,115200,$$(alfa_mtdlayout_8M),1638400,6291456,kernel.image,rootfs.image))