aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-08-17 06:16:54 +0000
committerJohn Crispin <john@openwrt.org>2015-08-17 06:16:54 +0000
commit4463bc017beba6be6c484f0ff5e9d381debafe38 (patch)
treef81909ba8f3ca67b7e791e950431ff609ccb1dc5 /target/linux/ar71xx/image/Makefile
parent9b0516c9fc993745cab983e9ada3e4b00185855c (diff)
downloadupstream-4463bc017beba6be6c484f0ff5e9d381debafe38.tar.gz
upstream-4463bc017beba6be6c484f0ff5e9d381debafe38.tar.bz2
upstream-4463bc017beba6be6c484f0ff5e9d381debafe38.zip
ar71xx: Add support for Black Swift
Add support for the Black Swift board: http://www.black-swift.com/ Took relevant parts and slightly adapted from: https://github.com/blackswift/openwrt/blob/master/bsb.patch Signed-off-by: Bruno Randolf <br1@einfach.org> SVN-Revision: 46651
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 2896c0101d..3508913dfc 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -172,6 +172,14 @@ define Device/Default
IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
endef
+define Device/bsb
+ BOARDNAME = BSB
+ IMAGE_SIZE = 16000k
+ CONSOLE = ttyATH0,115200
+ MTDPARTS = spi0.0:128k(u-boot)ro,64k(u-boot-env)ro,16128k(firmware),64k(art)ro
+endef
+TARGET_DEVICES += bsb
+
define Device/carambola2
BOARDNAME = CARAMBOLA2
IMAGE_SIZE = 16000k