aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-10-31 09:29:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-10-31 09:29:01 +0000
commit1bd87413e68d6b4c4db34b84a9929be875337bc9 (patch)
tree4226b624d987cf30fae130bf8be5e54d452e1f2e /target/linux/ar71xx/image/Makefile
parent153ed674b350b3550bf6d5f225f5dcb30135e5f3 (diff)
downloadupstream-1bd87413e68d6b4c4db34b84a9929be875337bc9.tar.gz
upstream-1bd87413e68d6b4c4db34b84a9929be875337bc9.tar.bz2
upstream-1bd87413e68d6b4c4db34b84a9929be875337bc9.zip
ar71xx/image: refactor templates tplink-chn-v2
SVN-Revision: 47316
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile16
1 files changed, 2 insertions, 14 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 8cfad76263..f0c3a66365 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -259,13 +259,6 @@ define Device/tplink
IMAGE/factory.bin := append-rootfs | mktplinkfw factory
endef
-define Device/tplink-chn-v2
-$(Device/tplink)
- TPLINK_HEADER_VERSION := 2
- IMAGE/sysupgrade.bin := append-rootfs | mktplinkfw sysupgrade
- IMAGE/factory.bin := append-rootfs | mktplinkfw factory
-endef
-
define Device/tplink-nolzma
$(Device/tplink)
LOADER_FLASH_OFFS := 0x22000
@@ -305,12 +298,6 @@ $(Device/tplink)
IMAGE_SIZE := 15872k
endef
-define Device/tplink-chn-v2-4mlzma
-$(Device/tplink-chn-v2)
- TPLINK_FLASHLAYOUT := 4Mlzma
- IMAGE_SIZE := 3904k
-endef
-
define Device/tl-wdr4300-v1
$(Device/tplink-8mlzma)
BOARDNAME = TL-WDR4300
@@ -346,10 +333,11 @@ endef
TARGET_DEVICES += tl-wdr3500-v1 tl-wdr3600-v1 tl-wdr4300-v1 tl-wdr4300-v1-il tl-wdr4310-v1 mw4530r-v1
define Device/tl-wdr3320-v2
-$(Device/tplink-chn-v2-4mlzma)
+$(Device/tplink-4mlzma)
BOARDNAME = TL-WDR3320-v2
DEVICE_PROFILE = TLWDR3320V2
TPLINK_HWID := 0x33200002
+ TPLINK_HEADER_VERSION := 2
endef
TARGET_DEVICES += tl-wdr3320-v2