aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-12-05 09:57:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-12-05 09:57:29 +0000
commit69c87b4f14fbe4ce35118a10c5b0956377fff8bf (patch)
tree49dade4b8f89db814ed63e7a2543ae1eb6c62979 /target/linux/ar71xx/image/Makefile
parenta51fcab27fba78deaf61d1be854dba38f62ace43 (diff)
downloadupstream-69c87b4f14fbe4ce35118a10c5b0956377fff8bf.tar.gz
upstream-69c87b4f14fbe4ce35118a10c5b0956377fff8bf.tar.bz2
upstream-69c87b4f14fbe4ce35118a10c5b0956377fff8bf.zip
CC: ar71xx: backport support for TP-LINK TL-WR841N/ND v10
The TL-WR841N/ND v10 is mostly identical to the v9. Apart from some minor changes, it contains a newer revision of the QCA9533 SoC and the CPU clock is significantly higher. Backport of r47263 Signed-off-by: Matteo Valentini <matteo.valentini@wiman.me> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47788 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 013a215c17..95d9a08003 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -546,6 +546,13 @@ define Device/tl-wr841n-v9
TPLINK_HWID := 0x08410009
endef
+define Device/tl-wr841n-v10
+ $(Device/tplink-4mlzma)
+ BOARDNAME := TL-WR841N-v9
+ DEVICE_PROFILE := TLWR841
+ TPLINK_HWID := 0x08410010
+endef
+
define Device/tl-wr842n-v2
$(Device/tplink-8mlzma)
BOARDNAME := TL-WR842N-v2
@@ -566,7 +573,7 @@ define Device/tl-wr847n-v8
DEVICE_PROFILE := TLWR841
TPLINK_HWID := 0x08470008
endef
-TARGET_DEVICES += tl-wr841n-v8 tl-wr841n-v9 tl-wr842n-v2 tl-wr843nd-v1 tl-wr847n-v8
+TARGET_DEVICES += tl-wr841n-v8 tl-wr841n-v9 tl-wr841n-v10 tl-wr842n-v2 tl-wr843nd-v1 tl-wr847n-v8
define Device/tl-wr941nd-v5
$(Device/tplink-4mlzma)