aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-06-18 20:24:26 +0000
committerJohn Crispin <blogic@openwrt.org>2015-06-18 20:24:26 +0000
commit60e365e854920a0ea6f763e062ac41570af61e01 (patch)
treebd1c508c638029a652627dad08fd4b478431cde6 /target/linux/ar71xx/image/Makefile
parent0aefa67f4322757fcb4710d7b0f296f15d02dcdb (diff)
downloadupstream-60e365e854920a0ea6f763e062ac41570af61e01.tar.gz
upstream-60e365e854920a0ea6f763e062ac41570af61e01.tar.bz2
upstream-60e365e854920a0ea6f763e062ac41570af61e01.zip
ar71xx: add support for TL-WR720N-v4.
The hardware should be almost the same as TL-WR720N-v3. WiFi and LAN networks were tested by "Lo Yuk Fai <loyukfai@gmail.com>". Failsafe and slider switch were tested by "Wong min <alpha080@gmail.com>". Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com> Backport of r46046 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46056 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index af53decc1f..a2a66b80b0 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -441,7 +441,15 @@ define Device/tl-wr720n-v3
TPLINK_HWID := 0x07200103
CONSOLE := ttyATH0,115200
endef
-TARGET_DEVICES += tl-wr703n-v1 tl-wr710n-v1 tl-wr710n-v2 tl-wr720n-v3
+
+define Device/tl-wr720n-v4
+ $(Device/tplink-4mlzma)
+ BOARDNAME := TL-WR720N-v3
+ DEVICE_PROFILE := TLWR720
+ TPLINK_HWID := 0x07200104
+ CONSOLE := ttyATH0,115200
+endef
+TARGET_DEVICES += tl-wr703n-v1 tl-wr710n-v1 tl-wr710n-v2 tl-wr720n-v3 tl-wr720n-v4
define Device/tl-wr740n-v4
$(Device/tplink-4mlzma)