aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-03-01 08:15:02 +0000
committerJohn Crispin <blogic@openwrt.org>2016-03-01 08:15:02 +0000
commit4f7d7866588bd098af53e3f659cd8863fc5ed0f1 (patch)
tree92ecf4851fad97abe68091271f70342c7920de2e /target/linux/ar71xx/image/Makefile
parentfe9611fb34cf4405b1068734c3c471027d2cb680 (diff)
downloadupstream-4f7d7866588bd098af53e3f659cd8863fc5ed0f1.tar.gz
upstream-4f7d7866588bd098af53e3f659cd8863fc5ed0f1.tar.bz2
upstream-4f7d7866588bd098af53e3f659cd8863fc5ed0f1.zip
ar71xx: add support for TP-LINK TL-WR941ND v6 (international version)
The international version is completely different from the already supported Chinese version. The WLAN of the QCA956x SoC used by this router has been fixed in r46948. This patch looks like it changes a lot in 700-MIPS-ath79-openwrt-machines.patch; that is not the case. Unfortunately, quilt decided to completely reorganize the Kconfig patch even though only a single section has been added. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> Backport of r47420 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@48860 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 24c60f58e3..8f01a441eb 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -598,6 +598,13 @@ define Device/tl-wr941nd-v5
TPLINK_HWID := 0x09410005
endef
+define Device/tl-wr941nd-v6
+ $(Device/tplink-4mlzma)
+ BOARDNAME := TL-WR941ND-v6
+ DEVICE_PROFILE := TLWR941
+ TPLINK_HWID := 0x09410006
+endef
+
# Chinese version (unlike European) is similar to the TL-WDR3500
define Device/tl-wr941nd-v6-cn
$(Device/tplink-4mlzma)
@@ -605,7 +612,7 @@ define Device/tl-wr941nd-v6-cn
DEVICE_PROFILE := TLWR941
TPLINK_HWID := 0x09410006
endef
-TARGET_DEVICES += tl-wr941nd-v5 tl-wr941nd-v6-cn
+TARGET_DEVICES += tl-wr941nd-v5 tl-wr941nd-v6 tl-wr941nd-v6-cn
define Device/tl-wr1041n-v2
$(Device/tplink-4mlzma)