aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-08-17 13:18:56 +0000
committerJohn Crispin <blogic@openwrt.org>2015-08-17 13:18:56 +0000
commit1cbb93865ed30fc4b23c3bf4a7839f170fafe46a (patch)
tree25160900b3ab73b5d01bbaf063c57c8a4e16b11c /target/linux/ar71xx/image/Makefile
parentfebf61a29a25e83ffbf3546dd385422ec9303e88 (diff)
downloadupstream-1cbb93865ed30fc4b23c3bf4a7839f170fafe46a.tar.gz
upstream-1cbb93865ed30fc4b23c3bf4a7839f170fafe46a.tar.bz2
upstream-1cbb93865ed30fc4b23c3bf4a7839f170fafe46a.zip
ar71xx: Add support for Black Swift
Add support for the Black Swift board: http://www.black-swift.com/ Took relevant parts and slightly adapted from: https://github.com/blackswift/openwrt/blob/master/bsb.patch Signed-off-by: Bruno Randolf <br1@einfach.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46674 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 3c77465e40..bb5de17fcf 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -120,6 +120,14 @@ define Device/Default
IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
endef
+define Device/bsb
+ BOARDNAME = BSB
+ IMAGE_SIZE = 16000k
+ CONSOLE = ttyATH0,115200
+ MTDPARTS = spi0.0:128k(u-boot)ro,64k(u-boot-env)ro,16128k(firmware),64k(art)ro
+endef
+TARGET_DEVICES += bsb
+
define Device/carambola2
BOARDNAME = CARAMBOLA2
IMAGE_SIZE = 16000k