aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-06-19 00:22:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-06-19 00:22:04 +0000
commitdacb6839c04fe00ed0efd3c5dfa117a74d5a7bc9 (patch)
tree290fdb9c70c457675881fa0746dea7e07d8ed91e /target/linux/ar71xx/image/Makefile
parentec9f3a661f3dc989e5d5f69470e8d16c1093a2c1 (diff)
downloadupstream-dacb6839c04fe00ed0efd3c5dfa117a74d5a7bc9.tar.gz
upstream-dacb6839c04fe00ed0efd3c5dfa117a74d5a7bc9.tar.bz2
upstream-dacb6839c04fe00ed0efd3c5dfa117a74d5a7bc9.zip
ar71xx: add support for the embeddedwireless Dorin board (based on patch by embeddedwireless.de)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32447 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 8eed67dc06..0a7d75a3df 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -675,6 +675,12 @@ define Image/Build/Profile/AP121MINI
$(call Image/Build/Template/$(fs_64k)/$(1),AthLzma,ap121-mini,$(ap121_mini_cmdline),$(ap121_mtdlayout_4M),917504,2818048,RKuImage)
endef
+ew-dorin_cmdline=board=EW-DORIN console=ttyATH0,115200
+ew-dorin_mtdlayout_4M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env),896k(kernel),2816k(rootfs),64k(art),3712k@0x50000(firmware)
+define Image/Build/Profile/EWDORIN
+ $(call Image/Build/Template/$(fs_64k)/$(1),AthLzma,ew-dorin,$(ew-dorin_cmdline),$(ew-dorin_mtdlayout_4M),917504,2883584,KRuImage)
+endef
+
ap81_cmdline=board=AP81 console=ttyS0,115200
define Image/Build/Profile/AP81
$(call Image/Build/Template/$(fs_64k)/$(1),AthGzip,ap81,$(ap81_cmdline),,1310720,6619136,KRuImage)
@@ -1068,6 +1074,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/DIR615E4,$(1))
$(call Image/Build/Profile/DIR825B1,$(1))
$(call Image/Build/Profile/EAP7660D,$(1))
+ $(call Image/Build/Profile/EWDORIN,$(1))
$(call Image/Build/Profile/FR54RTR,$(1))
$(call Image/Build/Profile/HORNETUB,$(1))
$(call Image/Build/Profile/JA76PF,$(1))