aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-24 05:58:31 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-24 05:58:31 +0000
commitd7ebcb828c1a253504889811ad3080a7dd864d01 (patch)
tree16193785b94c9ddeadfa40e137515865b0d81aa6 /target/linux/ar71xx/image/Makefile
parentc0739badb27ec0e7e1d4f67e4b55cc685ed1de15 (diff)
downloadupstream-d7ebcb828c1a253504889811ad3080a7dd864d01.tar.gz
upstream-d7ebcb828c1a253504889811ad3080a7dd864d01.tar.bz2
upstream-d7ebcb828c1a253504889811ad3080a7dd864d01.zip
ar71xx: image: use a common macro for UBNTXM/UBNTDEV
The firmware generation part is the same for both macros. Move that into a separate macro and use the new macro for Image/Build/UB{NTXM,DEV}. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38146 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile17
1 files changed, 4 insertions, 13 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 10ddf2ec3a..a0b6e6d629 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -487,9 +487,7 @@ define Image/Build/UAPPRO
endef
-Image/Build/UBNTXM/buildkernel=$(call MkuImageLzma,$(2),$(3) $(ubntxm_mtdlayout))
-
-define Image/Build/UBNTXM
+define Image/Build/UBNT2
$(call Sysupgrade/KRuImage,$(1),$(2),65536,6684672)
dd if=$(KDIR_TMP)/vmlinux-$(2).uImage of=$(KDIR_TMP)/vmlinux-$(2).uImage.bin bs=64k conv=sync
-$(STAGING_DIR_HOST)/bin/mkfwimage \
@@ -499,18 +497,11 @@ define Image/Build/UBNTXM
-o $(call factoryname,$(1),$(2))
endef
+Image/Build/UBNTXM/buildkernel=$(call MkuImageLzma,$(2),$(3) $(ubntxm_mtdlayout))
+Image/Build/UBNTXM=$(call Image/Build/UBNT2,$(1),$(2),$(ubntxm_mtdlayout),$(4),$(5),$(6),$(7))
Image/Build/UBDEV/buildkernel=$(call MkuImageLzma,$(2),$(3) $(ubdev_mtdlayout))
-
-define Image/Build/UBDEV
- $(call Sysupgrade/KRuImage,$(1),$(2),65536,6684672)
- dd if=$(KDIR_TMP)/vmlinux-$(2).uImage of=$(KDIR_TMP)/vmlinux-$(2).uImage.bin bs=64k conv=sync
- -$(STAGING_DIR_HOST)/bin/mkfwimage \
- -B $(4) -v $(5).$(6).v6.0.0-OpenWrt-$(REVISION) \
- -k $(KDIR_TMP)/vmlinux-$(2).uImage.bin \
- -r $(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
- -o $(call factoryname,$(1),$(2))
-endef
+Image/Build/UBDEV=$(call Image/Build/UBNT2,$(1),$(2),$(ubdev_mtdlayout),$(4),$(5),$(6),$(7))
Image/Build/UBNT/buildkernel=$(call PatchKernelLzma,$(2),$(3))