aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-07-12 13:38:40 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-07-12 13:38:40 +0000
commit42ee0d2a0f1ebf5c549805ac9d001ba486ba3982 (patch)
treed9fe7ec2832535ff27807278b8359a4dc094586b /target/linux/ar71xx/image/Makefile
parentcb32e76a01990169ac96d9ade4a5f39b39153ace (diff)
downloadupstream-42ee0d2a0f1ebf5c549805ac9d001ba486ba3982.tar.gz
upstream-42ee0d2a0f1ebf5c549805ac9d001ba486ba3982.tar.bz2
upstream-42ee0d2a0f1ebf5c549805ac9d001ba486ba3982.zip
ar71xx: build firmware image for the TP-Link TL-WDR4310 v1.0
The hardware for TP-Link TL-WDR4300 v1.1 and TL-WDR4310 v1.0 is identical, but requires different firmware headers: TL-WDR4300: 00000040 43 00 00 01 00 00 00 01 00 00 00 00 76 fb 83 40 |C...........v..@| TL-WDR4310: 00000040 43 10 00 01 00 00 00 01 00 00 00 00 38 2b 50 6c |C...........8+Pl| [juhosg: change commit message, use a different model name] Signed-off-by: Stefan Lippers-Hollmann <s.l-h@gmx.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32683 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 6e2180ea8e..6c2581ddb5 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -990,6 +990,7 @@ endef
tlwdr4300_cmdline=board=TL-WDR4300 console=ttyS0,115200
define Image/Build/Profile/TLWDR4300
$(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wdr4300-v1,$(tlwdr4300_cmdline),0x43000001,1,8Mlzma)
+ $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wdr4310-v1,$(tlwdr4300_cmdline),0x43100001,1,8Mlzma)
endef
wndr3700_cmdline=board=WNDR3700 console=ttyS0,115200