aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-11-04 18:37:09 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-11-04 18:37:09 +0000
commit355c50d67cd27db3e0e0d7e94f7d06c41abde457 (patch)
tree8e399d53e86e34056168e8b60e31bfa69298eff9 /target/linux/ar71xx/image/Makefile
parent38671e769caad346f43f7a082dc099336f526b54 (diff)
downloadupstream-355c50d67cd27db3e0e0d7e94f7d06c41abde457.tar.gz
upstream-355c50d67cd27db3e0e0d7e94f7d06c41abde457.tar.bz2
upstream-355c50d67cd27db3e0e0d7e94f7d06c41abde457.zip
ar71xx: move WNDR4300 profile to the nand subtarget
Signed-off-by: Stefan Agner <stefan@agner.ch> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38647 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index a0f34c7275..b1909ddcc7 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -874,8 +874,6 @@ $(eval $(call SingleProfile,Netgear,64kraw,WNDR3800,wndr3800,WNDR3700,ttyS0,1152
$(eval $(call SingleProfile,Netgear,64kraw,WNDRMAC,wndrmac,WNDR3700,ttyS0,115200,$$(wndr3700v2_mtdlayout),3701,WNDRMAC,"",-H 29763654+16+64))
$(eval $(call SingleProfile,Netgear,64kraw,WNDRMACV2,wndrmacv2,WNDR3700,ttyS0,115200,$$(wndr3700v2_mtdlayout),3701,WNDRMACv2,"",-H 29763654+16+128))
-$(eval $(call SingleProfile,NetgearNAND,64k,WNDR4300,wndr4300,WNDR4300,ttyS0,115200,$$(wndr4300_mtdlayout),3703,WNDR4300,"",-H 29763948+0+128+128+2x2+3x3))
-
$(eval $(call SingleProfile,OpenMesh,squashfs-only,OM2P,om2p,,,,OM2P))
$(eval $(call SingleProfile,OpenMesh,squashfs-only,MR600,mr600,,,,MR600))
@@ -1006,6 +1004,11 @@ $(eval $(call MultiProfile,Minimal,$(SINGLE_PROFILES)))
$(eval $(call MultiProfile,Madwifi,EAP7660D UBNTRS UBNTRSPRO UBNTLSSR71 WP543))
endif # ifeq ($(SUBTARGET),generic)
+ifeq ($(SUBTARGET),nand)
+$(eval $(call SingleProfile,NetgearNAND,64k,WNDR4300,wndr4300,WNDR4300,ttyS0,115200,$$(wndr4300_mtdlayout),3703,WNDR4300,"",-H 29763948+0+128+128+2x2+3x3))
+endif # ifeq ($(SUBTARGET),nand)
+
+
$(eval $(call MultiProfile,Default,$(SINGLE_PROFILES)))
define Image/Build/squashfs