aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-01-04 17:30:47 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-01-04 17:30:47 +0000
commit2526c08008cbd157f8dc9cd0a99f511f0bb2b95f (patch)
tree319ae382d2e5675cadf937aee2c4222bb298ec56 /target/linux/ar71xx/generic
parentb81818bf2f5a6e61300f146bf6dc6f97b31fdecd (diff)
downloadupstream-2526c08008cbd157f8dc9cd0a99f511f0bb2b95f.tar.gz
upstream-2526c08008cbd157f8dc9cd0a99f511f0bb2b95f.tar.bz2
upstream-2526c08008cbd157f8dc9cd0a99f511f0bb2b95f.zip
ar71xx: add support for TP-Link TL-MR3020
This patch adds support for the TP-Link device TL-MR3020 which is very similiar to the TL-WR703N. The TL-MR3020 uses 5 LEDs, 1 push button and a switch with 3 positions. Only four LEDs can be controlled via GPIO. The power LED is connected to the power supply. The WPS push button has been mapped to KEY_WPS_BUTTON. The two GPIO signals of the sliding switch have been mapped to BTN_0 and BTN_1. I have also setup a wiki page with details here: http://wiki.openwrt.org/toh/tp-link/tl-mr3020 USB is working and has been tested with USB mass storage and USB UMTS stick. Wifi also seems to work. Ethernet is working too. Signed-off-by: Christian Cier-Zniewski <c.cier@gmx.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29651 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index 8e0fa29e4a..c9f0cacb1e 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -5,6 +5,17 @@
# See /LICENSE for more information.
#
+define Profile/TLMR3020
+ NAME:=TP-LINK TL-MR3020
+ PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+define Profile/TLMR3020/Description
+ Package set optimized for the TP-LINK TL-MR3020.
+endef
+$(eval $(call Profile,TLMR3020))
+
+
define Profile/TLMR3220
NAME:=TP-LINK TL-MR3220
PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
@@ -32,6 +43,7 @@ define Profile/TLWR703
PACKAGES:=kmod-usb-core kmod-usb2
endef
+
define Profile/TLWR703/Description
Package set optimized for the TP-LINK TL-WR703N.
endef