aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-07-07 13:46:54 +0000
committerJohn Crispin <john@openwrt.org>2015-07-07 13:46:54 +0000
commit055663201b7ce579815ec1cd23424237aede5134 (patch)
tree49c47adec24bfb6b00c03a2b573ef21d9f72b8bb /target/linux/ar71xx/generic
parent9f2b8b3902c38dfd68db74a4c235c7f38f177822 (diff)
downloadupstream-055663201b7ce579815ec1cd23424237aede5134.tar.gz
upstream-055663201b7ce579815ec1cd23424237aede5134.tar.bz2
upstream-055663201b7ce579815ec1cd23424237aede5134.zip
ar71xx: Add Support for the Bitmain Antminer S3
This patch adds support for the Bitmain Antminer S3 Cryptocurrency Miner http://wiki.openwrt.org/toh/bitmain/s3 Signed-off-by: L. D. Pinney <ldpinney@gmail.com> SVN-Revision: 46236
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/antminer.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/antminer.mk b/target/linux/ar71xx/generic/profiles/antminer.mk
index 366982c885..404133b8ca 100644
--- a/target/linux/ar71xx/generic/profiles/antminer.mk
+++ b/target/linux/ar71xx/generic/profiles/antminer.mk
@@ -15,3 +15,14 @@ define Profile/ANTMINER_S1/Description
Package set optimized for the Bitmain Antminer S1.
endef
$(eval $(call Profile,ANTMINER_S1))
+
+define Profile/ANTMINER_S3
+ NAME:=Antminer S3
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-crypto-manager kmod-i2c-gpio-custom kmod-usb-hid
+endef
+
+
+define Profile/ANTMINER_S1/Description
+ Package set optimized for the Bitmain Antminer S3.
+endef
+$(eval $(call Profile,ANTMINER_S3))