aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-06-18 18:21:05 +0000
committerJohn Crispin <john@openwrt.org>2015-06-18 18:21:05 +0000
commit694dd581ebb2898854385e40655c5cd2a44424c3 (patch)
tree648e8b4eb12198dd43d81275e573f371fc545eed /target/linux/ar71xx/generic
parentcf1fb25e670b8b303a4507a5f42f544a12559136 (diff)
downloadupstream-694dd581ebb2898854385e40655c5cd2a44424c3.tar.gz
upstream-694dd581ebb2898854385e40655c5cd2a44424c3.tar.bz2
upstream-694dd581ebb2898854385e40655c5cd2a44424c3.zip
ar71xx: Add Support for the Bitmain Antminer S1
This patch adds support for the Bitmain Antminer S1 Cryptocurrency Miner http://wiki.openwrt.org/toh/bitmain/s1 Signed-off-by: L. D. Pinney <ldpinney@gmail.com> Acked-by: James Hilliard <james.hilliard1@gmail.com> SVN-Revision: 46044
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/antminer.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/antminer.mk b/target/linux/ar71xx/generic/profiles/antminer.mk
new file mode 100644
index 0000000000..366982c885
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/antminer.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ANTMINER_S1
+ NAME:=Antminer S1
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-crypto-manager kmod-i2c-gpio-custom kmod-usb-hid
+endef
+
+
+define Profile/ANTMINER_S1/Description
+ Package set optimized for the Bitmain Antminer S1.
+endef
+$(eval $(call Profile,ANTMINER_S1))