aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-08-27 14:55:38 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-08-27 14:55:38 +0000
commitf2030c311383875177fdbf8bd1882e28c808949d (patch)
tree85d9c112f78d7d8ac6cd5f64e0a08aa1c5428a7e /target/linux/ar71xx/generic
parentd65c06c15c41488b926eaa34ff3bf825be14b77d (diff)
downloadupstream-f2030c311383875177fdbf8bd1882e28c808949d.tar.gz
upstream-f2030c311383875177fdbf8bd1882e28c808949d.tar.bz2
upstream-f2030c311383875177fdbf8bd1882e28c808949d.zip
ar71xx: add profile for Allnet devices
Signed-off-by: Daniel Golle <dgolle@allnet.de> SVN-Revision: 33287
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/allnet.mk39
1 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/allnet.mk b/target/linux/ar71xx/generic/profiles/allnet.mk
new file mode 100644
index 0000000000..986b633533
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/allnet.mk
@@ -0,0 +1,39 @@
+#
+# Copyright (C) 20012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ALL0305
+ NAME:=Allnet ALL0305
+ PACKAGES:=fconfig kmod-ath5k -kmod-ath9k
+endef
+
+define Profile/ALL0305/Description
+ Package set optimized for the Allnet ALL0305.
+endef
+
+$(eval $(call Profile,ALL0305))
+
+define Profile/ALL0258N
+ NAME:=Allnet ALL0258N
+ PACKAGES:=uboot-envtools
+endef
+
+define Profile/ALL0258N/Description
+ Package set optimized for the Allnet ALL0258N.
+endef
+
+$(eval $(call Profile,ALL0258N))
+
+define Profile/ALL0315N
+ NAME:=Allnet ALL0315N
+ PACKAGES:=uboot-envtools
+endef
+
+define Profile/ALL0315N/Description
+ Package set optimized for the Allnet ALL0315N.
+endef
+
+$(eval $(call Profile,ALL0315N))