aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-12-12 16:49:52 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-12-12 16:49:52 +0000
commitd085aad2880f799cc09b03a3329635ad84551d3b (patch)
tree282232dd9d469ff4ec8246e5bf1ff27ffb8d23e9 /target/linux/ar71xx/generic
parentdcdfcb75f0271fd68613965f8e34a6bc16d717ab (diff)
downloadupstream-d085aad2880f799cc09b03a3329635ad84551d3b.tar.gz
upstream-d085aad2880f799cc09b03a3329635ad84551d3b.tar.bz2
upstream-d085aad2880f799cc09b03a3329635ad84551d3b.zip
ar71xx: add profile and build initramfs image for the WNDR4300
It is not yet possible to use the default squasfsh/jffs2 images on NAND flashes, so only initramfs image is supported for now. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 34650
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/netgear.mk15
1 files changed, 14 insertions, 1 deletions
diff --git a/target/linux/ar71xx/generic/profiles/netgear.mk b/target/linux/ar71xx/generic/profiles/netgear.mk
index fe136234f6..ff25f695a0 100644
--- a/target/linux/ar71xx/generic/profiles/netgear.mk
+++ b/target/linux/ar71xx/generic/profiles/netgear.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -15,3 +15,16 @@ define Profile/WNDR3700/Description
endef
$(eval $(call Profile,WNDR3700))
+
+
+define Profile/WNDR4300
+ NAME:=NETGEAR WNDR4300
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WNDR4300/Description
+ Package set optimized for the NETGEAR WNDR4300
+endef
+
+$(eval $(call Profile,WNDR4300))
+