aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorDaniel Dickinson <crazycshore@gmail.com>2012-09-06 18:15:26 +0000
committerDaniel Dickinson <crazycshore@gmail.com>2012-09-06 18:15:26 +0000
commitc3b7139ab229bba6f0368b5e8152fb6cf8aec008 (patch)
tree3fe8b0d363ce382759618ddd1fdd481462965db5 /target/linux/ar71xx/generic
parent31e063d212a4b5ee910041c072a5b611eec31578 (diff)
downloadupstream-c3b7139ab229bba6f0368b5e8152fb6cf8aec008.tar.gz
upstream-c3b7139ab229bba6f0368b5e8152fb6cf8aec008.tar.bz2
upstream-c3b7139ab229bba6f0368b5e8152fb6cf8aec008.zip
dir825b1: Add image for DIR-825-B1 that uses the whole flash (must first be flashed with the 'standard' image) and an image to revert the change to allow reversion to stock firmware.
SVN-Revision: 33326
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/d-link.mk40
1 files changed, 40 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/d-link.mk b/target/linux/ar71xx/generic/profiles/d-link.mk
index 98fe00fc2f..1691cade2f 100644
--- a/target/linux/ar71xx/generic/profiles/d-link.mk
+++ b/target/linux/ar71xx/generic/profiles/d-link.mk
@@ -50,6 +50,16 @@ endef
$(eval $(call Profile,DIR615E4))
+define Profile/DIR825B1_ALL
+ NAME:=D-Link DIR-825 rev. B1 - all flavours
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/DIR825B1_ALL/Description
+ Build all D-Link DIR-825 rev. B1 images
+endef
+
+$(eval $(call Profile,DIR825B1_ALL))
define Profile/DIR825B1
NAME:=D-Link DIR-825 rev. B1
@@ -58,6 +68,36 @@ endef
define Profile/DIR825B1/Description
Package set optimized for the D-Link DIR-825 rev. B1.
+ Copies the calibration data to the last erase block so that, if desired,
+ an image optimized for use with OpenWrt (access to full flash) can be flashed.
endef
$(eval $(call Profile,DIR825B1))
+
+define Profile/DIR825B1_OPENWRT
+ NAME:=D-Link DIR-825 rev. B1 optimized for OpenWrt
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/DIR825B1_OPENWRT/Description
+ Package set optimized for the D-Link DIR-825 rev. B1. running OpenWrt
+ Can only be flashed from OpenWrt because it requires that the calibration data
+ be on the last sector of the flash (which the 'standard' version that can be flashed from
+ stock will ensure).
+endef
+
+$(eval $(call Profile,DIR825B1_OPENWRT))
+
+define Profile/DIR825B1_TOSTOCK
+ NAME:=D-Link DIR-825 rev. B1 that undoes OpenWrt optimization
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/DIR825B1_TOSTOCK/Description
+ Package set optimized for the D-Link DIR-825 rev. B1. that undoes OpenWrt optimization
+ Copies the calibration data from the last erase block to the erase block normally used
+ by the stock firmware for said data.
+endef
+
+$(eval $(call Profile,DIR825B1_TOSTOCK))
+