aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-01-31 18:37:01 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-01-31 18:37:01 +0000
commit97e4ddd012546ecaf5dea609af784e339408e502 (patch)
tree8eac46502e53997f4879ba1ffb09f53d89a89364 /target/linux/ar71xx/generic
parent8766f32b8c10ec8f5a34c794397e90d8f9d5796a (diff)
downloadupstream-97e4ddd012546ecaf5dea609af784e339408e502.tar.gz
upstream-97e4ddd012546ecaf5dea609af784e339408e502.tar.bz2
upstream-97e4ddd012546ecaf5dea609af784e339408e502.zip
ar71xx: add support for TP-Link TL-MR11U
Adds support for TL-MR11U, a portable router with very similar hardware to the TL-WR703N and TL-MR3020, but with an onboard 2000mAh battery. Tested, working: All interfaces (Ethernet, 802.11n, USB) WPS & Reset switches (Power appears to be a hardware slider) Ethernet, Wifi, 3G LEDs (Power & charging LEDs hardware controlled) Sysupgrade [juhosg: fix indentations to use TABs instead of spaces, fix 3.2 patch breakage] Signed-off-by: Simon Taylor <simon.taylor.uk@gmail.com> SVN-Revision: 29972
Diffstat (limited to 'target/linux/ar71xx/generic')
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index e927696082..e2b97212bc 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -5,6 +5,17 @@
# See /LICENSE for more information.
#
+define Profile/TLMR11U
+ NAME:=TP-LINK TL-MR11U
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLMR11U/Description
+ Package set optimized for the TP-LINK TL-MR11U.
+endef
+$(eval $(call Profile,TLMR11U))
+
+
define Profile/TLMR3020
NAME:=TP-LINK TL-MR3020
PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev