aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-08-17 13:18:56 +0000
committerJohn Crispin <blogic@openwrt.org>2015-08-17 13:18:56 +0000
commit1cbb93865ed30fc4b23c3bf4a7839f170fafe46a (patch)
tree25160900b3ab73b5d01bbaf063c57c8a4e16b11c /target/linux/ar71xx/generic/profiles
parentfebf61a29a25e83ffbf3546dd385422ec9303e88 (diff)
downloadupstream-1cbb93865ed30fc4b23c3bf4a7839f170fafe46a.tar.gz
upstream-1cbb93865ed30fc4b23c3bf4a7839f170fafe46a.tar.bz2
upstream-1cbb93865ed30fc4b23c3bf4a7839f170fafe46a.zip
ar71xx: Add support for Black Swift
Add support for the Black Swift board: http://www.black-swift.com/ Took relevant parts and slightly adapted from: https://github.com/blackswift/openwrt/blob/master/bsb.patch Signed-off-by: Bruno Randolf <br1@einfach.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46674 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic/profiles')
-rw-r--r--target/linux/ar71xx/generic/profiles/smartelectronics.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/smartelectronics.mk b/target/linux/ar71xx/generic/profiles/smartelectronics.mk
new file mode 100644
index 0000000000..6d3dc8c345
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/smartelectronics.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/BSB
+ NAME:=Smart Electronics Black Swift board
+ PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+define Profile/BSB/Description
+ Package set optimized for the Smart Electronics Black Swift board.
+endef
+
+$(eval $(call Profile,BSB))