aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-11-25 16:15:40 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-11-25 16:15:40 +0000
commitb5de5e3e87d7b214e3ac941e298bf5c1504bff9d (patch)
tree94ab059e3d7f3a830fe7ad9ccfdc8f900876f90f /target/linux/ar71xx/generic/profiles
parent381c35f4523c6ce255017651d2fea91662f9bd37 (diff)
downloadupstream-b5de5e3e87d7b214e3ac941e298bf5c1504bff9d.tar.gz
upstream-b5de5e3e87d7b214e3ac941e298bf5c1504bff9d.tar.bz2
upstream-b5de5e3e87d7b214e3ac941e298bf5c1504bff9d.zip
AA: ar71xx: add profiles and build images for old PowerCloud System devices
Backport of r34195. [juhosg: - use 'PowerCloud Systems' instead of 'PCS' in the profiles - sort SingleProfile instances in image/Makefile] Signed-off-by: Daniel Dickinson <daniel@powercloudsystems.com> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@34340 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic/profiles')
-rw-r--r--target/linux/ar71xx/generic/profiles/pcs.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/pcs.mk b/target/linux/ar71xx/generic/profiles/pcs.mk
new file mode 100644
index 0000000000..1399ef4233
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/pcs.mk
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2012 PowerCloud Systems
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/UBDEV01
+ NAME:=PowerCloud Systems ubdev01 model
+ PACKAGES:=
+endef
+
+define Profile/UBDEV01/Description
+ Package set optimized for the PowerCloud Systems ubdev01 board.
+endef
+
+$(eval $(call Profile,UBDEV01))
+
+define Profile/DLRTDEV01
+ NAME:=PowerCloud Systems dlrtdev01 model
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/DLRTDEV01/Description
+ Package set optimized for the PowerCloud Systems dlrtdev01 board.
+endef
+
+$(eval $(call Profile,DLRTDEV01))