aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/ubnt.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-06-17 06:53:22 +0200
committerJo-Philipp Wich <jo@mein.io>2016-06-27 11:10:15 +0200
commit8d1218ca7370a84c886a63917ef857c92ab9f25f (patch)
tree7ef242271b390a72028771e96bf6a10b7a7d844a /target/linux/ar71xx/generic/profiles/ubnt.mk
parentdc140e00a93d54370021f819fd986290e8237cbe (diff)
downloadupstream-8d1218ca7370a84c886a63917ef857c92ab9f25f.tar.gz
upstream-8d1218ca7370a84c886a63917ef857c92ab9f25f.tar.bz2
upstream-8d1218ca7370a84c886a63917ef857c92ab9f25f.zip
ar71xx: merge profiles into image building code
- Remove old style device profiles and convert them to device definitions within the image building code - Fix the legacy build macros for the changed eval depth in the legacy image build wrapper Signed-off-by: John Crispin <john@phrozen.org> Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/ubnt.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/ubnt.mk95
1 files changed, 0 insertions, 95 deletions
diff --git a/target/linux/ar71xx/generic/profiles/ubnt.mk b/target/linux/ar71xx/generic/profiles/ubnt.mk
deleted file mode 100644
index 69b83985bd..0000000000
--- a/target/linux/ar71xx/generic/profiles/ubnt.mk
+++ /dev/null
@@ -1,95 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/UBNTRS
- NAME:=Ubiquiti RouterStation
- PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
-endef
-
-define Profile/UBNTRS/Description
- Package set optimized for the Ubiquiti RouterStation.
-endef
-
-$(eval $(call Profile,UBNTRS))
-
-define Profile/UBNTRSPRO
- NAME:=Ubiquiti RouterStation Pro
- PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
-endef
-
-define Profile/UBNTRSPRO/Description
- Package set optimized for the Ubiquiti RouterStation Pro.
-endef
-
-$(eval $(call Profile,UBNTRSPRO))
-
-define Profile/UBNTUNIFI
- NAME:=Ubiquiti UniFi AP
- PACKAGES:=
-endef
-
-define Profile/UBNTUNIFI/Description
- Package set optimized for the Ubiquiti UniFi AP.
-endef
-
-$(eval $(call Profile,UBNTUNIFI))
-
-define Profile/UBNTUNIFIACLITE
- NAME:=Ubiquiti UniFi AP AC LITE/LR
- PACKAGES:=kmod-ath10k ath10k-firmware-qca988x
-endef
-
-define Profile/UBNTUNIFIACLITE/Description
- Package set optimized for the Ubiquiti UniFi AP AC LITE/LR.
-endef
-
-$(eval $(call Profile,UBNTUNIFIACLITE))
-
-define Profile/UBNTUNIFIACPRO
- NAME:=Ubiquiti UniFi AP AC PRO
- PACKAGES:=kmod-ath10k ath10k-firmware-qca988x kmod-usb-core kmod-usb-ohci kmod-usb2
-endef
-
-define Profile/UBNTUNIFIACPRO/Description
- Package set optimized for the Ubiquiti UniFi AP AC PRO.
-endef
-
-$(eval $(call Profile,UBNTUNIFIACPRO))
-
-define Profile/UBNTUNIFIOUTDOOR
- NAME:=Ubiquiti UniFiAP Outdoor
- PACKAGES:=
-endef
-
-define Profile/UBNTUNIFIOUTDOOR/Description
- Package set optimized for the Ubiquiti UniFiAP Outdoor.
-endef
-
-$(eval $(call Profile,UBNTUNIFIOUTDOOR))
-
-define Profile/UAPPRO
- NAME:=Ubiquiti UniFi AP Pro
- PACKAGES:=
-endef
-
-define Profile/UAPPRO/Description
- Package set optimized for the Ubiquiti UniFi AP Pro.
-endef
-
-$(eval $(call Profile,UAPPRO))
-
-
-define Profile/UBNT
- NAME:=Ubiquiti Products
- PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
-endef
-
-define Profile/UBNT/Description
- Build images for all Ubiquiti products (including LS-SR71, RouterStation and RouterStation Pro)
-endef
-
-$(eval $(call Profile,UBNT))