aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/openmesh.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-06-17 06:53:22 +0200
committerJo-Philipp Wich <jo@mein.io>2016-06-27 11:10:15 +0200
commit8d1218ca7370a84c886a63917ef857c92ab9f25f (patch)
tree7ef242271b390a72028771e96bf6a10b7a7d844a /target/linux/ar71xx/generic/profiles/openmesh.mk
parentdc140e00a93d54370021f819fd986290e8237cbe (diff)
downloadupstream-8d1218ca7370a84c886a63917ef857c92ab9f25f.tar.gz
upstream-8d1218ca7370a84c886a63917ef857c92ab9f25f.tar.bz2
upstream-8d1218ca7370a84c886a63917ef857c92ab9f25f.zip
ar71xx: merge profiles into image building code
- Remove old style device profiles and convert them to device definitions within the image building code - Fix the legacy build macros for the changed eval depth in the legacy image build wrapper Signed-off-by: John Crispin <john@phrozen.org> Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/openmesh.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/openmesh.mk73
1 files changed, 0 insertions, 73 deletions
diff --git a/target/linux/ar71xx/generic/profiles/openmesh.mk b/target/linux/ar71xx/generic/profiles/openmesh.mk
deleted file mode 100644
index dbdf16959f..0000000000
--- a/target/linux/ar71xx/generic/profiles/openmesh.mk
+++ /dev/null
@@ -1,73 +0,0 @@
-#
-# Copyright (C) 2011-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/OM5P
- NAME:=OpenMesh OM5P/OM5P-AN
- PACKAGES:=kmod-ath9k om-watchdog
-endef
-
-define Profile/OM5P/Description
- Package set optimized for the OpenMesh OM5P/OM5P-AN.
-endef
-
-$(eval $(call Profile,OM5P))
-
-define Profile/OM5PAC
- NAME:=OpenMesh OM5P-AC/OM5P-ACv2
- PACKAGES:=kmod-ath9k kmod-ath10k om-watchdog
-endef
-
-define Profile/OM5PAC/Description
- Package set optimized for the OpenMesh OM5P-AC/OM5P-ACv2.
-endef
-
-$(eval $(call Profile,OM5PAC))
-
-define Profile/MR600
- NAME:=OpenMesh MR600
- PACKAGES:=kmod-ath9k om-watchdog
-endef
-
-define Profile/MR600/Description
- Package set optimized for the OpenMesh MR600.
-endef
-
-$(eval $(call Profile,MR600))
-
-define Profile/MR900
- NAME:=OpenMesh MR900/MR900v2
- PACKAGES:=kmod-ath9k om-watchdog
-endef
-
-define Profile/MR900/Description
- Package set optimized for the OpenMesh MR900/MR900v2.
-endef
-
-$(eval $(call Profile,MR900))
-
-define Profile/MR1750
- NAME:=OpenMesh MR1750/MR1750v2
- PACKAGES:=kmod-ath9k kmod-ath10k
-endef
-
-define Profile/MR1750/Description
- Package set optimized for the OpenMesh MR1750/MR1750v2.
-endef
-
-$(eval $(call Profile,MR1750))
-
-define Profile/OPENMESH
- NAME:=OpenMesh products
- PACKAGES:=kmod-ath9k kmod-ath10k om-watchdog
-endef
-
-define Profile/OPENMESH/Description
- Build images for all OpenMesh products.
-endef
-
-$(eval $(call Profile,OPENMESH))
-