aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/openmesh.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-06-23 19:33:07 +0200
committerJohn Crispin <john@phrozen.org>2016-06-23 19:33:31 +0200
commit387477350334daf8cd6adf72f63eddae83785614 (patch)
treeffa65aadbb9341ec560af9cd21879e8822e46ac2 /target/linux/ar71xx/generic/profiles/openmesh.mk
parentcb7aa4b1fee688342950d02195b927962295514e (diff)
downloadupstream-387477350334daf8cd6adf72f63eddae83785614.tar.gz
upstream-387477350334daf8cd6adf72f63eddae83785614.tar.bz2
upstream-387477350334daf8cd6adf72f63eddae83785614.zip
Revert "ar71xx: fix legacy image building"
This reverts commit 59e98b27c93d282edb62fad756fd1c1e587c067f. and Revert "ar71xx: merge profiles into image building code" This reverts commit 636089ead6864364798ac988299429d171051c0e. these are still causing issues Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/openmesh.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/openmesh.mk73
1 files changed, 73 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/openmesh.mk b/target/linux/ar71xx/generic/profiles/openmesh.mk
new file mode 100644
index 0000000000..dbdf16959f
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/openmesh.mk
@@ -0,0 +1,73 @@
+#
+# Copyright (C) 2011-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/OM5P
+ NAME:=OpenMesh OM5P/OM5P-AN
+ PACKAGES:=kmod-ath9k om-watchdog
+endef
+
+define Profile/OM5P/Description
+ Package set optimized for the OpenMesh OM5P/OM5P-AN.
+endef
+
+$(eval $(call Profile,OM5P))
+
+define Profile/OM5PAC
+ NAME:=OpenMesh OM5P-AC/OM5P-ACv2
+ PACKAGES:=kmod-ath9k kmod-ath10k om-watchdog
+endef
+
+define Profile/OM5PAC/Description
+ Package set optimized for the OpenMesh OM5P-AC/OM5P-ACv2.
+endef
+
+$(eval $(call Profile,OM5PAC))
+
+define Profile/MR600
+ NAME:=OpenMesh MR600
+ PACKAGES:=kmod-ath9k om-watchdog
+endef
+
+define Profile/MR600/Description
+ Package set optimized for the OpenMesh MR600.
+endef
+
+$(eval $(call Profile,MR600))
+
+define Profile/MR900
+ NAME:=OpenMesh MR900/MR900v2
+ PACKAGES:=kmod-ath9k om-watchdog
+endef
+
+define Profile/MR900/Description
+ Package set optimized for the OpenMesh MR900/MR900v2.
+endef
+
+$(eval $(call Profile,MR900))
+
+define Profile/MR1750
+ NAME:=OpenMesh MR1750/MR1750v2
+ PACKAGES:=kmod-ath9k kmod-ath10k
+endef
+
+define Profile/MR1750/Description
+ Package set optimized for the OpenMesh MR1750/MR1750v2.
+endef
+
+$(eval $(call Profile,MR1750))
+
+define Profile/OPENMESH
+ NAME:=OpenMesh products
+ PACKAGES:=kmod-ath9k kmod-ath10k om-watchdog
+endef
+
+define Profile/OPENMESH/Description
+ Build images for all OpenMesh products.
+endef
+
+$(eval $(call Profile,OPENMESH))
+