aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/openmesh.mk
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2016-09-21 21:13:17 +0200
committerGitHub <noreply@github.com>2016-09-21 21:13:17 +0200
commitd6b3ca24c50047af58135ad3090f7a3a25eee35d (patch)
tree396e8a75db1ad4deccaee1f3beb9373264454e84 /target/linux/ar71xx/generic/profiles/openmesh.mk
parent2a97364ad496e90fbf3dc723a7db44096a9955f6 (diff)
parent3411c9a885955875a02e764e34d5be21132a444e (diff)
downloadupstream-d6b3ca24c50047af58135ad3090f7a3a25eee35d.tar.gz
upstream-d6b3ca24c50047af58135ad3090f7a3a25eee35d.tar.bz2
upstream-d6b3ca24c50047af58135ad3090f7a3a25eee35d.zip
Merge pull request #82 from ecsv/openmesh-cc
OpenMesh MR1750(v2) and OM2P-HSv3 support for Chaos Calmer
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/openmesh.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/openmesh.mk28
1 files changed, 25 insertions, 3 deletions
diff --git a/target/linux/ar71xx/generic/profiles/openmesh.mk b/target/linux/ar71xx/generic/profiles/openmesh.mk
index 41b462e86b..e245e6c544 100644
--- a/target/linux/ar71xx/generic/profiles/openmesh.mk
+++ b/target/linux/ar71xx/generic/profiles/openmesh.mk
@@ -6,12 +6,12 @@
#
define Profile/OM2P
- NAME:=OpenMesh OM2P/OM2Pv2/OM2P-HS/OM2P-HSv2/OM2P-LC
+ NAME:=OpenMesh OM2P/OM2Pv2/OM2P-HS/OM2P-HSv2/OM2P-HSv3/OM2P-LC
PACKAGES:=kmod-ath9k om-watchdog
endef
define Profile/OM2P/Description
- Package set optimized for the OpenMesh OM2P/OM2Pv2/OM2P-HS/OM2P-HSv2/OM2P-LC.
+ Package set optimized for the OpenMesh OM2P/OM2Pv2/OM2P-HS/OM2P-HSv2/OM2P-HSv3/OM2P-LC.
endef
$(eval $(call Profile,OM2P))
@@ -27,6 +27,17 @@ endef
$(eval $(call Profile,OM5P))
+define Profile/OM5PAC
+ NAME:=OpenMesh OM5P-AC/OM5P-ACv2
+ PACKAGES:=kmod-ath9k kmod-ath10k om-watchdog ath10k-firmware-qca988x
+endef
+
+define Profile/OM5PAC/Description
+ Package set optimized for the OpenMesh OM5P-AC/OM5P-ACv2.
+endef
+
+$(eval $(call Profile,OM5PAC))
+
define Profile/MR600
NAME:=OpenMesh MR600
PACKAGES:=kmod-ath9k om-watchdog
@@ -49,9 +60,20 @@ endef
$(eval $(call Profile,MR900))
+define Profile/MR1750
+ NAME:=OpenMesh MR1750/MR1750v2
+ PACKAGES:=kmod-ath9k kmod-ath10k ath10k-firmware-qca988x
+endef
+
+define Profile/MR1750/Description
+ Package set optimized for the OpenMesh MR1750/MR1750v2.
+endef
+
+$(eval $(call Profile,MR1750))
+
define Profile/OPENMESH
NAME:=OpenMesh products
- PACKAGES:=kmod-ath9k om-watchdog
+ PACKAGES:=kmod-ath9k kmod-ath10k om-watchdog
endef
define Profile/OPENMESH/Description