aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/onion.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-08-03 10:22:33 +0000
committerJohn Crispin <blogic@openwrt.org>2015-08-03 10:22:33 +0000
commite443f119e1ea0e77e0d5c4531fe838dd2f431cb1 (patch)
treec8dae7d7be6e1abe11d535bb5702c64e5a12df64 /target/linux/ar71xx/generic/profiles/onion.mk
parentf732c67f8e0dbd67e4016e47facd7217be01d6d3 (diff)
downloadupstream-e443f119e1ea0e77e0d5c4531fe838dd2f431cb1.tar.gz
upstream-e443f119e1ea0e77e0d5c4531fe838dd2f431cb1.tar.bz2
upstream-e443f119e1ea0e77e0d5c4531fe838dd2f431cb1.zip
ar71xx: Backport support for Onion Omega
Backport of r46458 to CC https://onion.io/omega Signed-off-by: L. D. Pinney <ldpinney@gmail.com> Acked-by: Boken Lin <bl@onion.io> Tested-by: Jacky Huang <huangfangcheng@163.com> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46548 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/onion.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/onion.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/onion.mk b/target/linux/ar71xx/generic/profiles/onion.mk
new file mode 100644
index 0000000000..dd5874ea41
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/onion.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/OMEGA
+ NAME:=Onion Omega
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-usb-storage kmod-i2c-core kmod-i2c-gpio-custom kmod-spi-bitbang kmod-spi-dev kmod-spi-gpio kmod-spi-gpio-custom kmod-usb-serial
+endef
+
+define Profile/OMEGA/Description
+ Package set optimized for the Onion Omega development platform.
+endef
+$(eval $(call Profile,OMEGA))