aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/linksys.mk
diff options
context:
space:
mode:
authorGad Krumholz <gad.krumholz@gmail.com>2016-11-27 00:52:53 -0600
committerGad Krumholz <gad.krumholz@gmail.com>2016-11-30 00:47:10 -0600
commitd9740d24d767d583da08eeaa8bd7a01288fdc554 (patch)
tree5fda396bbe79871356ce3d25e2ed83ebcd3a0bfe /target/linux/ar71xx/generic/profiles/linksys.mk
parent1b6dc2e48ce654a004a7d0b98d7070a515424595 (diff)
downloadupstream-d9740d24d767d583da08eeaa8bd7a01288fdc554.tar.gz
upstream-d9740d24d767d583da08eeaa8bd7a01288fdc554.tar.bz2
upstream-d9740d24d767d583da08eeaa8bd7a01288fdc554.zip
CC: ar71xx: Added missing support for Linksys E2100L
It's based on the WRT160NL according to https://wiki.openwrt.org/toh/linksys/e2100l Based on research done here: https://forum.openwrt.org/viewtopic.php?id=24244 and here: https://forum.openwrt.org/viewtopic.php?pid=120791#p120791 this patch was conceived. Signed-off-by: Gad Krumholz <gad.krumholz@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/linksys.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/linksys.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/linksys.mk b/target/linux/ar71xx/generic/profiles/linksys.mk
index bedf3a3d49..973eb6e24a 100644
--- a/target/linux/ar71xx/generic/profiles/linksys.mk
+++ b/target/linux/ar71xx/generic/profiles/linksys.mk
@@ -14,6 +14,15 @@ define Profile/WRT160NL/Description
Package set optimized for the Linksys WRT160NL.
endef
+define Profile/E2100L
+ NAME:=Linksys E2100L
+ PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+define Profile/E2100L/Description
+ Package set optimized for the Linksys E2100L
+endef
+
define Profile/WRT400N
NAME:=Linksys WRT400N
PACKAGES:=
@@ -24,4 +33,5 @@ define Profile/WRT400N/Description
endef
$(eval $(call Profile,WRT160NL))
+$(eval $(call Profile,E2100L))
$(eval $(call Profile,WRT400N))