aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/files
diff options
context:
space:
mode:
authorHenryk Heisig <hyniu@o2.pl>2018-02-06 22:08:28 +0100
committerJohn Crispin <john@phrozen.org>2018-02-13 09:21:20 +0100
commita338491a306798868738fd8210b27bd2a4ab0daa (patch)
tree8ff16b02274a21dcd0d94d4d66f8cf59f430ed2c /target/linux/ar71xx/files
parent78f5af626c2da3816b71b5e4c560516f8ee383b2 (diff)
downloadupstream-a338491a306798868738fd8210b27bd2a4ab0daa.tar.gz
upstream-a338491a306798868738fd8210b27bd2a4ab0daa.tar.bz2
upstream-a338491a306798868738fd8210b27bd2a4ab0daa.zip
ar71xx: add support for TP-Link RE355
This device is identical as TP-Link RE450 RE355 is a dual-band AC1200 router, based on Qualcomm/Atheros QCA9558+QCA9880. Specification: 720/600/200 MHz (CPU/DDR/AHB) 64/128 MB of RAM (DDR2) 8 MB of FLASH (SPI NOR) 3T3R 2.4 GHz 3T3R 5 GHz 1x 10/100/1000 Mbps Ethernet 7x LED, 3x button UART header on PCB Flash instruction: Web: Download lede-ar71xx-generic-archer-c60-v2-squashfs-factory.bin and use OEM System Tools - Firmware Upgrade site. Signed-off-by: Henryk Heisig <hyniu@o2.pl>
Diffstat (limited to 'target/linux/ar71xx/files')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt10
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-re450.c62
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
4 files changed, 69 insertions, 5 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 20eb210105..eda1e4002b 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -1305,6 +1305,16 @@ config ATH79_MACH_MZK_W300NH
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
+config ATH79_MACH_RE355
+ bool "TP-LINK RE355 board support"
+ select SOC_QCA955X
+ select ATH79_DEV_AP9X_PCI if PCI
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_RE450
bool "TP-LINK RE450 board support"
select SOC_QCA955X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index 9be721ac20..27ef57d167 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -177,6 +177,7 @@ obj-$(CONFIG_ATH79_MACH_RB941) += mach-rb941.o
obj-$(CONFIG_ATH79_MACH_RB95X) += mach-rb95x.o
obj-$(CONFIG_ATH79_MACH_RBSPI) += mach-rbspi.o
obj-$(CONFIG_ATH79_MACH_RBSXTLITE) += mach-rbsxtlite.o
+obj-$(CONFIG_ATH79_MACH_RE355) += mach-re450.o
obj-$(CONFIG_ATH79_MACH_RE450) += mach-re450.o
obj-$(CONFIG_ATH79_MACH_RUT9XX) += mach-rut9xx.o
obj-$(CONFIG_ATH79_MACH_RW2458N) += mach-rw2458n.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-re450.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-re450.c
index 25de6e729f..991aa1c9a9 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/mach-re450.c
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-re450.c
@@ -1,9 +1,10 @@
/*
- * TP-LINK Archer RE450 board support
+ * TP-LINK RE355/RE450 board support
*
* Copyright (c) 2013 Gabor Juhos <juhosg@openwrt.org>
* Copyright (c) 2016 Tal Keren <kooolk@gmail.com>
- *
+ * Copyright (c) 2018 Henryk Heisig <hyniu@o2.pl>
+ *
* Based on the Qualcomm Atheros AP135/AP136 reference board support code
* Copyright (c) 2012 Qualcomm Atheros
*
@@ -72,6 +73,42 @@ static struct flash_platform_data tl_re450_flash_data = {
.part_probes = tl_re450_part_probes,
};
+static struct gpio_led re355_leds_gpio[] __initdata = {
+ {
+ .name = "re355:blue:power",
+ .gpio = RE450_GPIO_LED_SYSTEM,
+ .active_low = 1,
+ },
+ {
+ .name = "re355:blue:wlan2g",
+ .gpio = RE450_GPIO_LED_WLAN2G,
+ .active_low = 1,
+ },
+ {
+ .name = "re355:blue:wlan5g",
+ .gpio = RE450_GPIO_LED_WLAN5G,
+ .active_low = 1,
+ },
+ {
+ .name = "re355:blue:wps",
+ .gpio = RE450_GPIO_LED_JUMPSTART,
+ },
+ {
+ .name = "re355:red:wps",
+ .gpio = RE450_GPIO_LED_JUMPSTART_RED,
+ },
+ {
+ .name = "re355:green:lan_data",
+ .gpio = RE450_GPIO_LED_LAN_DATA,
+ .active_low = 1,
+ },
+ {
+ .name = "re355:green:lan_link",
+ .gpio = RE450_GPIO_LED_LAN_LINK,
+ .active_low = 1,
+ },
+};
+
static struct gpio_led re450_leds_gpio[] __initdata = {
{
.name = "re450:blue:power",
@@ -149,15 +186,13 @@ static struct platform_device re450_phy_device = {
},
};
-static void __init re450_setup(void)
+static void __init rex5x_setup(void)
{
u8 *mac = (u8 *) KSEG1ADDR(0x1f610008);
u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
u8 tmpmac[ETH_ALEN];
ath79_register_m25p80(&tl_re450_flash_data);
- ath79_register_leds_gpio(-1, ARRAY_SIZE(re450_leds_gpio),
- re450_leds_gpio);
ath79_register_gpio_keys_polled(-1, RE450_KEYS_POLL_INTERVAL,
ARRAY_SIZE(re450_gpio_keys),
re450_gpio_keys);
@@ -183,5 +218,22 @@ static void __init re450_setup(void)
ath79_register_eth(0);
}
+static void __init re355_setup(void)
+{
+ rex5x_setup();
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(re355_leds_gpio),
+ re355_leds_gpio);
+}
+
+MIPS_MACHINE(ATH79_MACH_RE355, "RE355", "TP-LINK RE355",
+ re355_setup)
+
+static void __init re450_setup(void)
+{
+ rex5x_setup();
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(re450_leds_gpio),
+ re450_leds_gpio);
+}
+
MIPS_MACHINE(ATH79_MACH_RE450, "RE450", "TP-LINK RE450",
re450_setup)
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index 7434f340af..27269e54d6 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -207,6 +207,7 @@ enum ath79_mach_type {
ATH79_MACH_RB_WAPAC, /* Mikrotik RouterBOARD wAPG-5HacT2HnD */
ATH79_MACH_RB_SXTLITE2ND, /* Mikrotik RouterBOARD SXT Lite 2nD */
ATH79_MACH_RB_SXTLITE5ND, /* Mikrotik RouterBOARD SXT Lite 5nD */
+ ATH79_MACH_RE355, /* TP-LINK RE355 */
ATH79_MACH_RE450, /* TP-LINK RE450 */
ATH79_MACH_RUT9XX, /* Teltonika RUT900 series */
ATH79_MACH_RW2458N, /* Redwave RW2458N */