aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/files
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2017-07-02 18:32:38 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2017-07-04 08:58:54 +0200
commit6165e4aab0e22b780b6b1dde887ed803a7c8210a (patch)
tree4f95e80fcccc02122231d83e6f1579f8a97490af /target/linux/ar71xx/files
parent0a2e4204dbe0b7bf31cb4100491a01b2837d7f3f (diff)
downloadupstream-6165e4aab0e22b780b6b1dde887ed803a7c8210a.tar.gz
upstream-6165e4aab0e22b780b6b1dde887ed803a7c8210a.tar.bz2
upstream-6165e4aab0e22b780b6b1dde887ed803a7c8210a.zip
ar71xx: add support for TP-Link TL-WR902AC v1
TP-Link TL-WR902AC v1 is a pocket-size, dual-band (AC750), successor of TL-MR3020 (both devices use very similar enclosure, in same size). New device is based on Qualcomm QCA9531 v2 + QCA9887. FCC ID: TE7WR902AC. Specification: - 650/391/216 MHz (CPU/DDR/AHB) - 1x 10/100 Mbps Ethernet - 1x USB 2.0 (GPIO-controlled power) - 64 MB of RAM (DDR2) - 8 MB of FLASH - 2T2R 2.4 GHz (QCA9531) - 1T1R 5 GHz (QCA9887) - 5x LED (GPIO-controlled), 2x button, 1x 3-pos switch - UART pads on PCB (TP1 -> TX, TP2 -> RX, TP3 -> GND, TP4 -> 3V3, jumper resitors are missing on TX/RX lines) - 1x micro USB (for power only) Flash instructions: Use "factory" image under vendor GUI. Recovery instructions: This device contains tftp recovery mode inside U-Boot. You can use it to flash LEDE (use "factory" image) or vendor firmware. 1. Configure PC with static IP 192.168.0.66/24 and tftp server. 2. Rename "lede-ar71xx-generic-tl-wr902ac-v1-squashfs-factory.bin" to "wr902acv1_un_tp_recovery.bin" and place it in tftp server dir. 3. Connect PC with LAN port, press the reset button, power up the router and keep button pressed until WPS LED lights up. 4. Router will download file from server, write it to flash and reboot. Root access over serial line in vendor firmware: root/sohoadmin. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/files')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt11
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wr902ac-v1.c140
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
4 files changed, 153 insertions, 0 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 0584e3896b..055dddf33d 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -1696,6 +1696,17 @@ config ATH79_MACH_TL_WR841N_V9
select ATH79_DEV_USB
select ATH79_DEV_WMAC
+config ATH79_MACH_TL_WR902AC_V1
+ bool "TP-LINK TL-WR902AC v1 support"
+ select SOC_QCA953X
+ select ATH79_DEV_AP9X_PCI if PCI
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_TL_WR941ND
bool "TP-LINK TL-WR941ND support"
select SOC_AR913X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index dd0b729996..3f589f7e2e 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -215,6 +215,7 @@ obj-$(CONFIG_ATH79_MACH_TL_WR840N_V2) += mach-tl-wr841n-v9.o
obj-$(CONFIG_ATH79_MACH_TL_WR841N_V1) += mach-tl-wr841n.o
obj-$(CONFIG_ATH79_MACH_TL_WR841N_V8) += mach-tl-wr841n-v8.o
obj-$(CONFIG_ATH79_MACH_TL_WR841N_V9) += mach-tl-wr841n-v9.o
+obj-$(CONFIG_ATH79_MACH_TL_WR902AC_V1) += mach-tl-wr902ac-v1.o
obj-$(CONFIG_ATH79_MACH_TL_WR941ND) += mach-tl-wr941nd.o
obj-$(CONFIG_ATH79_MACH_TL_WR941ND_V6) += mach-tl-wr941nd-v6.o
obj-$(CONFIG_ATH79_MACH_TL_WR940N_V4) += mach-tl-wr940n-v4.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wr902ac-v1.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wr902ac-v1.c
new file mode 100644
index 0000000000..5d7582232c
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wr902ac-v1.c
@@ -0,0 +1,140 @@
+/*
+ * TP-Link TL-WR902AC v1 board support
+ *
+ * Copyright (C) 2017 Piotr Dymacz <pepe2k@gmail.com>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-ap9x-pci.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+
+#define TL_WR902AC_V1_GPIO_LED_LAN 12
+#define TL_WR902AC_V1_GPIO_LED_POWER 13
+#define TL_WR902AC_V1_GPIO_LED_USB 4
+#define TL_WR902AC_V1_GPIO_LED_WLAN2G 11
+#define TL_WR902AC_V1_GPIO_LED_WPS 0
+
+#define TL_WR902AC_V1_GPIO_BTN_RESET 3
+#define TL_WR902AC_V1_GPIO_BTN_SW1 17
+#define TL_WR902AC_V1_GPIO_BTN_SW2 14
+#define TL_WR902AC_V1_GPIO_BTN_WPS 2
+
+#define TL_WR902AC_V1_GPIO_USB_POWER 1
+
+#define TL_WR902AC_V1_KEYS_POLL_INTERVAL 20 /* msecs */
+#define TL_WR902AC_V1_KEYS_DEBOUNCE_INTERVAL \
+ (3 * TL_WR902AC_V1_KEYS_POLL_INTERVAL)
+
+static struct gpio_led tl_wr902ac_v1_leds_gpio[] __initdata = {
+ {
+ .name = "tl-wr902ac-v1:green:lan",
+ .gpio = TL_WR902AC_V1_GPIO_LED_LAN,
+ .active_low = 1,
+ }, {
+ .name = "tl-wr902ac-v1:green:power",
+ .gpio = TL_WR902AC_V1_GPIO_LED_POWER,
+ .active_low = 0,
+ }, {
+ .name = "tl-wr902ac-v1:green:usb",
+ .gpio = TL_WR902AC_V1_GPIO_LED_USB,
+ .active_low = 0,
+ }, {
+ .name = "tl-wr902ac-v1:green:wlan2g",
+ .gpio = TL_WR902AC_V1_GPIO_LED_WLAN2G,
+ .active_low = 1,
+ }, {
+ .name = "tl-wr902ac-v1:green:wps",
+ .gpio = TL_WR902AC_V1_GPIO_LED_WPS,
+ .active_low = 1,
+ }
+};
+
+static struct gpio_keys_button tl_wr902ac_v1_gpio_keys[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = TL_WR902AC_V1_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = TL_WR902AC_V1_GPIO_BTN_RESET,
+ .active_low = 1,
+ }, {
+ .desc = "sw1",
+ .type = EV_KEY,
+ .code = BTN_0,
+ .debounce_interval = TL_WR902AC_V1_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = TL_WR902AC_V1_GPIO_BTN_SW1,
+ .active_low = 1,
+ }, {
+ .desc = "sw2",
+ .type = EV_KEY,
+ .code = BTN_1,
+ .debounce_interval = TL_WR902AC_V1_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = TL_WR902AC_V1_GPIO_BTN_SW2,
+ .active_low = 1,
+ }, {
+ .desc = "wps",
+ .type = EV_KEY,
+ .code = KEY_WPS_BUTTON,
+ .debounce_interval = TL_WR902AC_V1_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = TL_WR902AC_V1_GPIO_BTN_WPS,
+ .active_low = 1,
+ }
+};
+
+static void __init tl_wr902ac_v1_setup(void)
+{
+ u8 *art = (u8 *) KSEG1ADDR(0x1f7f0000);
+ u8 *mac = (u8 *) KSEG1ADDR(0x1f750008);
+
+ ath79_register_m25p80(NULL);
+
+ ath79_setup_ar933x_phy4_switch(false, false);
+ ath79_register_mdio(0, 0x0);
+
+ /* LAN */
+ ath79_switch_data.phy4_mii_en = 1;
+ ath79_eth0_data.duplex = DUPLEX_FULL;
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+ ath79_eth0_data.phy_mask = BIT(4);
+ ath79_eth0_data.speed = SPEED_100;
+
+ ath79_init_mac(ath79_eth0_data.mac_addr, mac, 1);
+ ath79_register_eth(0);
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(tl_wr902ac_v1_leds_gpio),
+ tl_wr902ac_v1_leds_gpio);
+
+ ath79_register_gpio_keys_polled(-1, TL_WR902AC_V1_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(tl_wr902ac_v1_gpio_keys),
+ tl_wr902ac_v1_gpio_keys);
+
+ gpio_request_one(TL_WR902AC_V1_GPIO_USB_POWER,
+ GPIOF_OUT_INIT_HIGH | GPIOF_EXPORT_DIR_FIXED,
+ "USB power");
+
+ ath79_register_usb();
+
+ ath79_register_wmac(art + 0x1000, mac);
+
+ ap91_pci_init(art + 0x5000, NULL);
+}
+
+MIPS_MACHINE(ATH79_MACH_TL_WR902AC_V1, "TL-WR902AC-V1", "TP-LINK TL-WR902AC v1",
+ tl_wr902ac_v1_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index dde6d9735a..0b70256338 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -262,6 +262,7 @@ enum ath79_mach_type {
ATH79_MACH_TL_WR841N_V9, /* TP-LINK TL-WR841N/ND v9 */
ATH79_MACH_TL_WR842N_V2, /* TP-LINK TL-WR842N/ND v2 */
ATH79_MACH_TL_WR842N_V3, /* TP-LINK TL-WR842N/ND v3 */
+ ATH79_MACH_TL_WR902AC_V1, /* TP-LINK TL-WR902AC v1 */
ATH79_MACH_TL_WR941ND, /* TP-LINK TL-WR941ND */
ATH79_MACH_TL_WR941ND_V5, /* TP-LINK TL-WR941ND v5 */
ATH79_MACH_TL_WR941ND_V6, /* TP-LINK TL-WR941ND v6 */