aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/files
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2016-10-08 03:36:35 +0200
committerJohn Crispin <john@phrozen.org>2016-11-21 10:05:40 +0100
commite33dcd1cfe105cb0e1ad09887144e4911eac653f (patch)
treec51e1a2a3d0ffbb7f1dfb74414b9911eda6a3430 /target/linux/ar71xx/files
parentdcceea4fd3ac40db872a4feec23f656fa60fd0b3 (diff)
downloadupstream-e33dcd1cfe105cb0e1ad09887144e4911eac653f.tar.gz
upstream-e33dcd1cfe105cb0e1ad09887144e4911eac653f.tar.bz2
upstream-e33dcd1cfe105cb0e1ad09887144e4911eac653f.zip
ar71xx: add support for YunCore CPE830
CPE830 is a clone of AP90Q, with different type of antenna (panel) and additional 4 LEDs for WiFi signal level indication. Use the same flash approach as for YunCore AP90Q. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/files')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt9
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-ap90q.c130
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
4 files changed, 115 insertions, 26 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 6daa093a01..001edbeb17 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -1211,6 +1211,15 @@ config ATH79_MACH_CPE510
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
+config ATH79_MACH_CPE830
+ bool "YunCore CPE830 support"
+ select SOC_QCA953X
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_CPE870
bool "YunCore CPE870 support"
select SOC_AR934X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index b718d6bfd3..ac2dbbb23f 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -75,6 +75,7 @@ obj-$(CONFIG_ATH79_MACH_CF_E380AC_V2) += mach-cf-e316n-v2.o
obj-$(CONFIG_ATH79_MACH_CF_E520N) += mach-cf-e316n-v2.o
obj-$(CONFIG_ATH79_MACH_CF_E530N) += mach-cf-e316n-v2.o
obj-$(CONFIG_ATH79_MACH_CPE510) += mach-cpe510.o
+obj-$(CONFIG_ATH79_MACH_CPE830) += mach-ap90q.o
obj-$(CONFIG_ATH79_MACH_CPE870) += mach-cpe870.o
obj-$(CONFIG_ATH79_MACH_CR3000) += mach-cr3000.o
obj-$(CONFIG_ATH79_MACH_CR5000) += mach-cr5000.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-ap90q.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-ap90q.c
index 35e578122e..2e9d34d658 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/mach-ap90q.c
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-ap90q.c
@@ -1,5 +1,7 @@
/*
- * YunCore AP90Q board support
+ * Support for YunCore boards:
+ * - AP90Q
+ * - CPE830
*
* Copyright (C) 2016 Piotr Dymacz <pepe2k@gmail.com>
*
@@ -23,6 +25,7 @@
#include "dev-wmac.h"
#include "machtypes.h"
+/* AP90Q */
#define AP90Q_GPIO_LED_WAN 4
#define AP90Q_GPIO_LED_WLAN 12
#define AP90Q_GPIO_LED_LAN 16
@@ -61,40 +64,62 @@ static struct gpio_keys_button ap90q_gpio_keys[] __initdata = {
},
};
-static void __init ap90q_gpio_setup(void)
-{
- /* For LED on GPIO4 */
- ath79_gpio_function_disable(AR934X_GPIO_FUNC_CLK_OBS4_EN);
-
- ath79_gpio_direction_select(AP90Q_GPIO_LED_LAN, true);
- ath79_gpio_direction_select(AP90Q_GPIO_LED_WAN, true);
- ath79_gpio_direction_select(AP90Q_GPIO_LED_WLAN, true);
-
- /* Mute LEDs on boot */
- gpio_set_value(AP90Q_GPIO_LED_LAN, 1);
- gpio_set_value(AP90Q_GPIO_LED_WAN, 1);
-
- ath79_gpio_output_select(AP90Q_GPIO_LED_LAN, 0);
- ath79_gpio_output_select(AP90Q_GPIO_LED_WAN, 0);
- ath79_gpio_output_select(AP90Q_GPIO_LED_WLAN, 0);
+/* CPE830 */
+#define CPE830_GPIO_LED_LINK4 0
+#define CPE830_GPIO_LED_LINK1 1
+#define CPE830_GPIO_LED_LINK2 2
+#define CPE830_GPIO_LED_LINK3 3
+#define CPE830_GPIO_LED_WAN 4
+#define CPE830_GPIO_LED_WLAN 12
+#define CPE830_GPIO_LED_LAN 16
- ath79_register_leds_gpio(-1, ARRAY_SIZE(ap90q_leds_gpio),
- ap90q_leds_gpio);
+#define CPE830_GPIO_BTN_RESET 17
- ath79_register_gpio_keys_polled(-1, AP90Q_KEYS_POLL_INTERVAL,
- ARRAY_SIZE(ap90q_gpio_keys),
- ap90q_gpio_keys);
-}
+static struct gpio_led cpe830_leds_gpio[] __initdata = {
+ {
+ .name = "cpe830:green:lan",
+ .gpio = CPE830_GPIO_LED_LAN,
+ .active_low = 1,
+ },
+ {
+ .name = "cpe830:green:wan",
+ .gpio = CPE830_GPIO_LED_WAN,
+ .active_low = 1,
+ },
+ {
+ .name = "cpe830:green:wlan",
+ .gpio = CPE830_GPIO_LED_WLAN,
+ .active_low = 1,
+ },
+ {
+ .name = "cpe830:green:link1",
+ .gpio = CPE830_GPIO_LED_LINK1,
+ .active_low = 1,
+ },
+ {
+ .name = "cpe830:green:link2",
+ .gpio = CPE830_GPIO_LED_LINK2,
+ .active_low = 1,
+ },
+ {
+ .name = "cpe830:green:link3",
+ .gpio = CPE830_GPIO_LED_LINK3,
+ .active_low = 1,
+ },
+ {
+ .name = "cpe830:green:link4",
+ .gpio = CPE830_GPIO_LED_LINK4,
+ .active_low = 1,
+ },
+};
-static void __init ap90q_setup(void)
+static void __init ap90q_cpe830_common_setup(void)
{
u8 *art = (u8 *) KSEG1ADDR(0x1fff1000);
u8 *mac = (u8 *) KSEG1ADDR(0x1fff0000);
ath79_register_m25p80(NULL);
- ap90q_gpio_setup();
-
ath79_setup_ar933x_phy4_switch(false, false);
ath79_register_mdio(0, 0x0);
@@ -118,6 +143,59 @@ static void __init ap90q_setup(void)
ath79_register_eth(0);
ath79_register_wmac(art, NULL);
+
+ /* For LED on GPIO4 */
+ ath79_gpio_function_disable(AR934X_GPIO_FUNC_CLK_OBS4_EN);
+
+ ath79_gpio_direction_select(AP90Q_GPIO_LED_LAN, true);
+ ath79_gpio_direction_select(AP90Q_GPIO_LED_WAN, true);
+ ath79_gpio_direction_select(AP90Q_GPIO_LED_WLAN, true);
+
+ /* Mute LEDs on boot */
+ gpio_set_value(AP90Q_GPIO_LED_LAN, 1);
+ gpio_set_value(AP90Q_GPIO_LED_WAN, 1);
+
+ ath79_gpio_output_select(AP90Q_GPIO_LED_LAN, 0);
+ ath79_gpio_output_select(AP90Q_GPIO_LED_WAN, 0);
+ ath79_gpio_output_select(AP90Q_GPIO_LED_WLAN, 0);
+
+ ath79_register_gpio_keys_polled(-1, AP90Q_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(ap90q_gpio_keys),
+ ap90q_gpio_keys);
+}
+
+static void __init ap90q_setup(void)
+{
+ ap90q_cpe830_common_setup();
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(ap90q_leds_gpio),
+ ap90q_leds_gpio);
}
MIPS_MACHINE(ATH79_MACH_AP90Q, "AP90Q", "YunCore AP90Q", ap90q_setup);
+
+static void __init cpe830_setup(void)
+{
+ ap90q_cpe830_common_setup();
+
+ ath79_gpio_direction_select(CPE830_GPIO_LED_LINK1, true);
+ ath79_gpio_direction_select(CPE830_GPIO_LED_LINK2, true);
+ ath79_gpio_direction_select(CPE830_GPIO_LED_LINK3, true);
+ ath79_gpio_direction_select(CPE830_GPIO_LED_LINK4, true);
+
+ /* Mute LEDs on boot */
+ gpio_set_value(CPE830_GPIO_LED_LINK1, 1);
+ gpio_set_value(CPE830_GPIO_LED_LINK2, 1);
+ gpio_set_value(CPE830_GPIO_LED_LINK3, 1);
+ gpio_set_value(CPE830_GPIO_LED_LINK4, 1);
+
+ ath79_gpio_output_select(CPE830_GPIO_LED_LINK1, 0);
+ ath79_gpio_output_select(CPE830_GPIO_LED_LINK2, 0);
+ ath79_gpio_output_select(CPE830_GPIO_LED_LINK3, 0);
+ ath79_gpio_output_select(CPE830_GPIO_LED_LINK4, 0);
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(cpe830_leds_gpio),
+ cpe830_leds_gpio);
+}
+
+MIPS_MACHINE(ATH79_MACH_CPE830, "CPE830", "YunCore CPE830", cpe830_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index 50ecff46f5..9a8da22f65 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -61,6 +61,7 @@ enum ath79_mach_type {
ATH79_MACH_CF_E530N, /* COMFAST CF-E530N */
ATH79_MACH_CPE210, /* TP-LINK CPE210 */
ATH79_MACH_CPE510, /* TP-LINK CPE510 */
+ ATH79_MACH_CPE830, /* YunCore CPE830 */
ATH79_MACH_CPE870, /* YunCore CPE870 */
ATH79_MACH_CR3000, /* PowerCloud CR3000 */
ATH79_MACH_CR5000, /* PowerCloud CR5000 */