aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/files/arch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-19 17:58:05 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-19 17:58:05 +0000
commitd5ba886ca6de7dd6ea20fd8b3deb8a6675646826 (patch)
tree10c22d4fc3070cc5c70b6fe625d5e8c544f23e09 /target/linux/ar71xx/files/arch
parent2830947555b70b6dd5a2da8f5d7d3db6b4903f52 (diff)
downloadupstream-d5ba886ca6de7dd6ea20fd8b3deb8a6675646826.tar.gz
upstream-d5ba886ca6de7dd6ea20fd8b3deb8a6675646826.tar.bz2
upstream-d5ba886ca6de7dd6ea20fd8b3deb8a6675646826.zip
ar71xx: Add Gainstrong MiniBox v1.0 support to 15.05
This patch supersedes the v1 from September 17th. Bumping the patch version - the MiniBox profile showed up under M, but since it's called 'Gainstrong MiniBox v1.0' now it looks out of place. Renamed the profile to gs-minibox-v1.mk to fix that. The following patch adds support for the Gainstrong MiniBox to 15.05 Chaos Calmer. Fixed items: - Inverted LED polarity (OOLITE seems to suffer from the same problem). - Changed uppercase MINIBOX_V1_ prefix as requested. - Prefixes are now gs_minibox_ similar to gs_oolite_ (same vendor). - Mention the vendor (Gainstrong) in code headers. Compiles fine, has been confirmed working by owners. Question: I've seen some boards use tools/firmware-utils/src/mktplinkfw.c, the MiniBox images build fine without, so I'm wondering: do I need to add it in there as well? Any added benefit? Thank you Signed-off by: Stijn Segers <francesco.borromini@inventati.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47235 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/files/arch')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-gs-minibox-v1.c85
1 files changed, 85 insertions, 0 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-gs-minibox-v1.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-gs-minibox-v1.c
new file mode 100644
index 0000000000..47eeb65de8
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-gs-minibox-v1.c
@@ -0,0 +1,85 @@
+/*
+ * Gainstrong MiniBox V1.0 board support
+ *
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define GS_MINIBOX_V1_GPIO_BTN_RESET 11
+
+#define GS_MINIBOX_V1_GPIO_LED_SYSTEM 1
+
+#define GS_MINIBOX_V1_KEYS_POLL_INTERVAL 20 /* msecs */
+#define GS_MINIBOX_V1_KEYS_DEBOUNCE_INTERVAL (3 * GS_MINIBOX_V1_KEYS_POLL_INTERVAL)
+
+static const char *gs_minibox_v1_part_probes[] = {
+ "tp-link",
+ NULL,
+};
+
+static struct flash_platform_data gs_minibox_v1_flash_data = {
+ .part_probes = gs_minibox_v1_part_probes,
+};
+
+static struct gpio_led gs_minibox_v1_leds_gpio[] __initdata = {
+ {
+ .name = "minibox-v1:green:system",
+ .gpio = GS_MINIBOX_V1_GPIO_LED_SYSTEM,
+ .active_low = 1,
+ },
+};
+
+static struct gpio_keys_button gs_minibox_v1_gpio_keys[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = GS_MINIBOX_V1_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = GS_MINIBOX_V1_GPIO_BTN_RESET,
+ .active_low = 0,
+ },
+};
+
+static void __init gs_minibox_v1_setup(void)
+{
+ u8 *mac = (u8 *) KSEG1ADDR(0x1f01fc00);
+ u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(gs_minibox_v1_leds_gpio),
+ gs_minibox_v1_leds_gpio);
+
+ ath79_register_gpio_keys_polled(-1, GS_MINIBOX_V1_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(gs_minibox_v1_gpio_keys),
+ gs_minibox_v1_gpio_keys);
+
+ ath79_register_usb();
+
+ ath79_register_m25p80(&gs_minibox_v1_flash_data);
+ ath79_init_mac(ath79_eth0_data.mac_addr, mac, 1);
+ ath79_init_mac(ath79_eth1_data.mac_addr, mac, -1);
+
+ ath79_register_mdio(0, 0x0);
+ ath79_register_eth(1);
+ ath79_register_eth(0);
+
+ ath79_register_wmac(ee, mac);
+}
+
+MIPS_MACHINE(ATH79_MACH_GS_MINIBOX_V1, "MINIBOX-V1",
+ "MiniBox V1.0", gs_minibox_v1_setup);