aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/files/arch/mips/ath79/Makefile
diff options
context:
space:
mode:
authorThibaut VARENE <hacks@slashdirt.org>2017-02-07 12:06:33 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-15 11:28:57 +0100
commitc59fa94eeecf16c79254ab4bc78f5b31c7387039 (patch)
treea659eeca6219f7c7f252da490866739ff22b0c83 /target/linux/ar71xx/files/arch/mips/ath79/Makefile
parentd1a75c5161bbd1cdc148a8d8a5b0b71936dce08d (diff)
downloadupstream-c59fa94eeecf16c79254ab4bc78f5b31c7387039.tar.gz
upstream-c59fa94eeecf16c79254ab4bc78f5b31c7387039.tar.bz2
upstream-c59fa94eeecf16c79254ab4bc78f5b31c7387039.zip
ar71xx: add support for RB mAP L-2nD
This patch adds support for the MikroTik RouterBOARD mAP lite https://routerboard.com/RBmAPL-2nD Specifications: - SoC: Qualcomm QCA9533 (650MHz) - RAM: 64MB - Storage: 16MB NOR SPI flash - Wireless: builtin QCA9533, 2x2:2 - Ethernet: 1x100M This is another 16M SPI NOR mikrotik device. The machine file is named mach-rbspi.c because I plan to add support for several of the other spi-based RouterBOARD devices in subsequent patches: they share most of the hardware and thus the same codebase. Signed-off-by: Thibaut VARENE <hacks@slashdirt.org>
Diffstat (limited to 'target/linux/ar71xx/files/arch/mips/ath79/Makefile')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index aab8d6e8d0..e0748b1237 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -153,6 +153,7 @@ obj-$(CONFIG_ATH79_MACH_RB91X) += mach-rb91x.o
obj-$(CONFIG_ATH79_MACH_RB922) += mach-rb922.o
obj-$(CONFIG_ATH79_MACH_RB941) += mach-rb941.o
obj-$(CONFIG_ATH79_MACH_RB95X) += mach-rb95x.o
+obj-$(CONFIG_ATH79_MACH_RBSPI) += mach-rbspi.o
obj-$(CONFIG_ATH79_MACH_RBSXTLITE) += mach-rbsxtlite.o
obj-$(CONFIG_ATH79_MACH_RE450) += mach-re450.o
obj-$(CONFIG_ATH79_MACH_RW2458N) += mach-rw2458n.o