aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/files/arch/mips/ath79/Makefile
diff options
context:
space:
mode:
authorShuanglin Liu <roboidler@gmail.com>2017-03-03 01:23:50 +0800
committerPiotr Dymacz <pepe2k@gmail.com>2017-03-12 17:38:31 +0100
commit53ef20f65acdcd068b1166d2522dcbe7d7e298c4 (patch)
tree6e6d29ed06c159cca3652b42326052277802f0ec /target/linux/ar71xx/files/arch/mips/ath79/Makefile
parent3183015e1e1573eae69717f66685c880439c7f2f (diff)
downloadupstream-53ef20f65acdcd068b1166d2522dcbe7d7e298c4.tar.gz
upstream-53ef20f65acdcd068b1166d2522dcbe7d7e298c4.tar.bz2
upstream-53ef20f65acdcd068b1166d2522dcbe7d7e298c4.zip
ar71xx: add support for Rockeetech AP531B0
Specification: - SoC: Qualcomm Atheros QCA9531 (650/400/216 MHz (CPU/DDR/AHB)) - RAM: 64 MiB DDR2 - Storage: 16 MiB of flash (optional 16 MiB second flash) - Wireless: built into QCA9531 (Honey Bee), PHY modes b/g/n - Ethernet: 1x100M (port0) 1x100M (port 4) - PCI-E: x1 - SIMcard slot: x1 - USB 2.0 port: x1 (optional) - Ext GPIO pin: x8 - UART for serial console: x1 - External watchdog: x1 (optional) - Power supply: 9-48V (DC jack/passive PoE) Installation through tftp: - Copy <Firmware Image Name> into tftp directory - Connect board via ttl port and Ethernet port - Boot the AP531B0 - When "Autobooting in 1 seconds" appears press Enter - Set serverip and ipaddr appropriate (e.g. setenv serverip 192.168.88.10;setenv ipaddr 192.168.88.1) - Enter "tftp 0x8050000 <Firmware Image Name>" - Enter "erase 0x9f050000 +$filesize" - Enter "cp.b 0x80500000 0x9f050000 $filesize" - Enter "reset" Signed-off-by: Shuanglin Liu <roboidler@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/files/arch/mips/ath79/Makefile')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index 64752591d5..73832448cd 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -53,6 +53,7 @@ obj-$(CONFIG_ATH79_MACH_AP136) += mach-ap136.o
obj-$(CONFIG_ATH79_MACH_AP143) += mach-ap143.o
obj-$(CONFIG_ATH79_MACH_AP147) += mach-ap147.o
obj-$(CONFIG_ATH79_MACH_AP152) += mach-ap152.o
+obj-$(CONFIG_ATH79_MACH_AP531B0) += mach-ap531b0.o
obj-$(CONFIG_ATH79_MACH_AP90Q) += mach-ap90q.o
obj-$(CONFIG_ATH79_MACH_AP96) += mach-ap96.o
obj-$(CONFIG_ATH79_MACH_ARCHER_C59_V1) += mach-archer-c59-v1.o