aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/files/arch/mips/ath79/Makefile
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2017-10-17 23:30:01 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2018-01-15 00:12:13 +0100
commit2e5252d346e2ec832a203af778b5c1d949f0ae5f (patch)
treee52b574b76b90886364ab22f96ae028daad48eb4 /target/linux/ar71xx/files/arch/mips/ath79/Makefile
parent6cf682e214910e0bbef440f372fd63590733a24b (diff)
downloadupstream-2e5252d346e2ec832a203af778b5c1d949f0ae5f.tar.gz
upstream-2e5252d346e2ec832a203af778b5c1d949f0ae5f.tar.bz2
upstream-2e5252d346e2ec832a203af778b5c1d949f0ae5f.zip
ar71xx: add support for GL.iNet GL-AR750
GL.iNet GL-AR750 is a small size, dual-band (AC750) router, based on Qualcomm/Atheros QCA9531 v2 + QCA9887. FCC ID: 2AFIW-AR750. Specification: - 650/597/216 MHz (CPU/DDR/AHB) - 128 MB of RAM (DDR2) - 16 MB of FLASH (SPI NOR) - 3x 10/100 Mbps Ethernet - 2T2R 2.4 GHz (QCA9531) - 1T1R 5 GHz (QCA9887) - 1x USB 2.0 (power controlled by GPIO) - 1x microSD (GL857L) - 3x LED (all driven by GPIO) - 1x button (reset) - 1x 2-pos switch - header for optional PoE module - 1x micro USB for main power input - UART + I2C header on PCB Flash instruction: Vendor firmware is based on OpenWrt/LEDE. GUI or sysupgrade can be used to flash OpenWrt/LEDE firmware. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ar71xx/files/arch/mips/ath79/Makefile')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index b7caa5a770..e9f4d9852b 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -122,6 +122,7 @@ obj-$(CONFIG_ATH79_MACH_FRITZ300E) += mach-fritz300e.o
obj-$(CONFIG_ATH79_MACH_GL_AR150) += mach-gl-ar150.o
obj-$(CONFIG_ATH79_MACH_GL_AR300) += mach-gl-ar300.o
obj-$(CONFIG_ATH79_MACH_GL_AR300M) += mach-gl-ar300m.o
+obj-$(CONFIG_ATH79_MACH_GL_AR750) += mach-gl-ar750.o
obj-$(CONFIG_ATH79_MACH_GL_DOMINO) += mach-gl-domino.o
obj-$(CONFIG_ATH79_MACH_GL_INET) += mach-gl-inet.o
obj-$(CONFIG_ATH79_MACH_GL_MIFI) += mach-gl-mifi.o